Главное меню

Основное меню

Меню «Файл»

Новый – создание нового планшета (загрузка непрерывных кривых в форматах LAS, импорт кривых из текстовых файлов);

Редактировать – режим создания и редактирования макета планшета;

Открыть – открывает файлы планшета в формате *.hjb;

Сохранить – сохраняет текущий планшет в файл *.hjb;

Сохранить как – предлагает сохранить текущий планшет в файл *.hjb под другим именем

Закрыть – завершает работу с текущим планшетом;

Экспорт в LAS – сохраняет кривую в файле формата LAS с заданным шагом по глубине;

Экспорт в LAS всех таблиц – сохраняет все кривые проекта в файле формата LAS с заданным шагом по глубине;

Экспорт в Базу Данных – запускает приложение экспорта параметров интерпретации в БД;

Печать – печать планшета;

Просмотр перед печатью – подготовка и просмотр геофизического планшета перед печатью;

Параметры страницы – настройки принтера перед печатью геофизического планшета;

Печать в файл – сохранение планшета в графическом виде;

Выход – выход из программы.

Меню «Редакция»

Откатить – отменить изменения;

Отменить все интервалы – отменяет все выделенные ранее интервалы на планшете;

Убрать репера в активном окне – удаляет все репера в активном поле планшета;

Убрать все репера – удаляет репера во всех полях планшета;

Задать дату измерений – позволяет задать или изменить дату начала измерений.

Удалить точки в интервале – удаляет точки с кривых в выделенных интервалах. (См. описание кнопки [image])

Задать значение в интервале – присваивает кривой задаваемое значение в выделенных интервалах.

Меню «Вид»

Панель инструментов – включает главную панель инструментов планшета;

Строка состояния – включает строку состояния в нижней части планшета. В строке состояния выводятся координаты курсора для активной кривой или колонки (время и значение);

Окно курсоров - включает панель переключения текущих курсоров;

Окно расчета методики – включает окно методик интерпретации;

Окно сглаживания – открывает окно выбора сглаживающего фильтра;

Окно калькулятора – открывает окно выбора калькуляторных методик;

Окно выбора цикла – открывает панель с набором элементов для построения колонок (литология, конструкция скважины, цементирование и т.д.).

Окно текущей модели – открывает панель с описанием текущей пластовой модели и кнопкой ее изменения;

Окно быстрого запуска методики – открывает панель с иконками быстрого доступа к методикам программы.

Меню «Опции»

Конфигурации – предоставляет возможность выбора или создания файла конфигурации планшета;

Шрифты – выбор шрифтов для оформления рабочего окна и твердой копии планшета;

Соотношения окон– устанавливает соотношение окон «Кривая», «Колодец», «Конструкция» при просмотре на экране и при печати;

Протокол – сохранение в файле *. txt информации по скважине;

Задать файл заключения Excel – предлагает выбрать путь к файлу, куда будет записываться заключение;

Путь к приложениям БД – предлагает выбрать путь к приложениям для работы с БД (для версии с базой данных)

Меню «Окно»

Восстановить – открывает все поля (окна) планшета и выравнивает их размеры;

Выровнять – выравнивает по ширине только открытые поля планшета;

Свойства – открывает окно свойств активного поля (окна) планшета;

Гидра | Просмотр перед печатью – одновременно открыты два окна. В одном – сам планшет, во втором окне справа - просмотр планшета перед печатью;

Гидра | Протокол – одновременно открыты два окна. В одном – сам планшет, во втором окне - протокол;

Под чертой в меню перечислены номера рабочих окон планшета. Отрытые в данный момент окна помечены «галочкой». Чтобы восстановить скрытое окно, необходимо щелкнуть в этой строке меню мышкой.

Меню «Кроссплоты»

Открыть - открывает кроссплот в формате *.hxp.

Меню «Помощь»

Справка – Загружает этот файл;

Подсказка дня - открывает случайную подсказку о полезных функциях программы;

О программе – информация о версии программы.


Назначение кнопок панели инструментов

Панель инструментов содержит набор кнопок, ускоряющих доступ к наиболее часто востребованным функциям управления планшетом и командам при интерпретации данных.

Функциональное назначение кнопок панели инструментов:

- создает новый планшет

- открывает файлы с расширением «hjb»

- сохраняет файл

- выводит планшет на печать

- открывает окно создания и редактирования макета планшета

- задание даты начала измерений

- управление временами циклов и их параметрами

- открывает окно интерпретационных технологий

- открывает окно расчета по методике пользователя

- активизирует окно сглаживающего фильтра кривых

- активизирует окно склейки кривых по времени

- активизирует опцию нормализации кривых

- открывает окно нормализации по опорным интервалам

- присваивает активной кривой статус «Базовая кривая» (в задачах увязки по времени)

- автоматическая увязка кривых по установленным реперам

- отображение на планшете пластовых границ

- отображение сетки на планшете

- активизирует окно рабочего набора данных

- активизирует окно мини-РНД для нефти

- активизирует окно мини-РНД для газа

- выводит окно исходных данных и алгоритмов расчета PVT-свойств флюидов

- интерпретация кривых давления по пластовой модели

- редакция предыстории работы скважины

- активизирует окно ввода результатов инклинометрии

- вызывает окно импорта и редакции кривых в таблицах

- режим курсора мыши «выбор активного элемента планшета»

- режим курсора мыши «вставить элемент колодца»

- режим курсора мыши «заменить элемент колодца»

- режим выделения рабочих интервалов разреза, в которых выполняется интерпретация данных

- режим установки реперов в полях планшета

- перемещение кривой(ых) по времени;


Горячие клавиши

Alt + Q - растягивание планшета по вертикали

Alt + W - сжатие планшета по вертикали

Alt + A - растягивает кривую по горизонтали

Alt + S - сжимает кривую по горизонтали

Ctrl + P - переход к печати планшета

Ctrl + A - предварительный просмотр перед печатью

Ctrl + Z - операция отмены

Ctrl + клик правой кнопкой мыши - переключение режимов курсора мыши между состояниями [image] и , [image] ;

при работе в колодце времен - между состояниями [image] и [image].

Ctrl + Shift - изменение курсора мыши на «прицел»

Ctrl + Shift + клик левой кнопкой мыши - изменение курсора мыши на «прицел» и привязка к активной кривой (просмотр значений в точках кривой, графическое редактирование кривой стрелками).

Ctrl + Shift + клавиши [image] [image] – редактирует (сдвигает) значения в точке на кривой

Ctrl + нажатая левая кнопка мыши - перетаскивание кривой в другое окно

Shift + нажатая левая кнопка мыши - перетаскивание окна целиком

Ctrl + Shift + D – удаление точек на кривой

Ctrl + D - Удаление точек в интервалах.

Ctrl + E - Присвоение значений точкам кривой (кривых) в активном окне для выделенных интервалов

Колесо мыши - прокрутка планшета

- прокрутка планшета вниз

- прокрутка планшета вверх

Page Down - прокрутка планшета вниз на страницу

Page Up - прокрутка планшета вверх на страницу


Панель быстрого запуска методик

Для ускоренного доступа к методикам предусмотрена специальная панель инструментов. Вызвать ее можно в меню "Вид" -> "Окно быстрого запуска методики".

Функциональное назначение кнопок панели инструментов:

- Пересчет давления на отметку ВНК

- Пересчет давления на отметку ГВК

- Пересчет давления на кровлю перфорации

- Забойное давление остановленной газовой скважины

- Просмотр кривых на кроссплоте

- Просмотр кривых на кроссплоте в масштабе LOG-LOG

- Фазовые проницаемости

- Свойства нефти

- Свойства газа

- Дебит по забойному давлению

- Дебит по данным промысла

- Дебит газовой скважины по ДИКТ

- Дебит по продуктивности

- Дебит по послепритоку

- Забойное давление и дебит по уровням

- Метод индикаторной для жидкости

- Метод индикаторной для газа

- Метод Яковлева для КВУ

- Нестабильный расход (метод совмещения)

- Метод Маскета для КВУ

- Нестабильный расход (дифференциальный метод)

- Нестабильный расход (интегральный метод)

- Плотность по забойному давлению

- Расчет прямой задачи

- Планирование исследований


Загрузка кривых из LAS, TBL, AGL

Загрузка осуществляется в окне "Макет" (Файл -> Новый, Файл -> Редактировать) с помощью кнопки "из LAS, TBL, AGL".

После выбора файла на экране появится диалог:

В таблице перечислены кривые, которые доступны в этом ЛАСе. Щелкая левой кнопкой мыши на их имена, можно выбрать нужные для загрузки кривые. С помощью кнопки "Выбрать все" можно выделить все кривые, имеющиеся в файле.

Кнопка "Кодировка DOS" предназначена для переключения кодировки кириллицы, если файл был записан программой, работающей под DOS.

Поле Дата LAS отображает дату, прочитанную из ЛАСа, она может быть по желанию пользователя изменена.

Опция "Считать поле START в LAS равным нолю" сдвигает начало кривой на относительный ноль.

По кнопке ОК все выбранные кривые загружаются в макет (см. Настройка макета).


Импорт кривых из текстовых файлов

Импорт осуществляется в окне "Макет" (Файл -> Новый, Файл -> Редактировать) с помощью кнопки "из TXT файла".

После выбора файла на экране появится диалог:

С помощью переключателей выбирается разделитель столбцов, а также целой и дробной части. Далее указывается с какой строки начать импорт (для случаев, когда над данными есть шапка). Чтобы не высчитывать номер строки вручную, просто произведите двойной клик на строчке, с которой нужно начать импорт - ее номер автоматически занесется в соответствующее поле.

Также нужно указать в каком столбце находится время.

Поле Дата файла при загрузке текстового файла необходимо заполнить вручную.

Формат времени в текстовом файле может быть произвольным. Поэтому в программе, кроме простых форматов, предусмотрено введение пользовательских форматов.

По кнопке "Добавить" появляется следующий диалог:

Здесь можно с помощью кнопок в верхней части диалога набрать требуемую маску формата времени и даты. Затем формату дается имя, и по кнопке ОК он появится в выпадающем списке первого диалога. Также форматы можно изменять и удалять.

Кнопка "Кодировка DOS" предназначена для переключения кодировки кириллицы, если файл был записан программой, работающей под DOS.

Опция "Обнулять начальное смещение" сдвигает начало кривой на относительный ноль.

По кнопке ОК появляется следующий этап импорта:

В таблице отображается время в формате программы, а также столбцы данных. Тип "Данные" в заголовке столбца можно сменить на "Не брать", тогда столбец не будет загружаться. Также можно сразу задать имя кривым в поле Имя, тогда они попадут в макет уже под своими именами.

Если был выбран неверный формат времени или неправильный разделитель столбцов, можно вернуться на предыдущий этап с помощью кнопки "Назад".

По кнопке Готово все выбранные кривые загружаются в макет (см. Настройка макета).


Импорт кривых из буфера обмена

Импорт осуществляется в окне "Макет" (Файл -> Новый, Файл -> Редактировать) с помощью кнопки "из TXT файла".

Если Вы предварительно скопировали в буфер обмена Windows текст из текстового файла, LAS-файла, таблицы Excel и т.д., программа предложит использовать его для импорта:

Если Вы выберете Yes, то вместо выбора файла сразу перейдете к таблице импорта, где в текстовом поле увидите скопированный текст.

Дальнейший действия будут аналогичны Импорту из текстового файла.

Если Вы выберете No, будет использован стандартный импорт из текстового файла.


Импорт кривых из таблиц XLS

Загрузка осуществляется в окне "Макет" (Файл -> Новый, Файл -> Редактировать) с помощью кнопки "из XLS таблицы".

Процесс загрузки кривых аналогичен описанному в разделе "Импорт из Excel и редакция кривых в таблице".

Отличие заключается в том, что загрузка и редакция уже существующих кривых отключена, и можно только добавить новые кривые в макет.

По кнопке ОК все выбранные кривые загружаются в макет (см. Настройка макета).


Настройка макета

Настройка макета

Каждой загружаемому элементу присваивается уникальный номер N по порядку ввода данных. За номером следует колонка с типом загружаемых данных. Номер и тип элемента планшета не редактируются. За номером следует колонка со стандартным именем. Выбирать его необязательно, однако после импорта, если имя кривой не было задано, при выборе стандартного имени само имя кривой заполнится автоматически. Также автоматически назначится единица измерения новой кривой.

Имя задается в колонке «Имя». Далее идет столбец единиц измерения. По клику в это поле пользователю будет предложен диалог выбора физической величины, представляемой этой кривой и единиц ее измерения. Большинство методик программы требует на вход кривые определенной физической величины, например, давление и расход жидкости. Если единицы измерения не заданы, методика предложит задать их перед расчетом.

Если Вы забыли присвоить имя хотя бы одной из кривых, программа не позволит перейти к этапу визуализации планшета на экране.

При повторении имени кривой программа сообщит об ошибке и потребует его исправления.

Все кривые загружаются в нулевое окно. Для визуализации кривой на экране, ее надо поместить в какое либо окно - для этого щелкните мышкой в колонке «Окно», в активной строке появится мигающий курсор, задайте необходимый номер окна.

В дальнейшем, любую кривую можно переместить в нулевое окно, если необходимо чтобы она хранилась в файле, а на экране ее не было. Достать кривую из нулевого окна можно также нажав правую кнопку мыши в любом окне с кривыми рабочего экрана и выбрав опцию "Достать из нулевого окна".

В этом окне можно загрузить кривые в макет из разных источников.

Для этого предназначена группа "Загрузка кривых", и, соответственно, кнопки

"из LAS, TBL, AGL",

"из TXT файла",

"из XLS таблицы".

После загрузки кривых можно установить интервал времен для начальный визуализации.

Автоматически при первой загрузке времена будут выбраны так, чтобы перекрывать все загруженные кривые. Начальное и конечное времена можно указать вручную в соответствующих полях в верхней части окна «Макет», либо времена установятся автоматически при нажатии кнопки «Взять из таблицы». В последнем случае интервал глубин будет считан из поля активной кривой, выделенной цветом, и занесен в поля «начальное» и «конечное» время.

С помощью кнопки «Удалить» можно удалить из списка выбранные данные. С помощью кнопки «Клонировать» выбранные кривые копируются и помещаются в то же окно, с новым именем.

Кнопка «Свойства» служит для доступа к настройкам свойств выделенной в списке (активной) кривой. Доступ к свойствам кривой имеется и из графического планшета. Подробно об этом написано в разделе «Свойства кривой».

Возможно сортировать данные в таблице по типу и номеру окна, названию нажатием на заголовок соответствующего столбца.

Если Вы что-то испортили - нажмите кнопку «Отмена», окно макета закроется, сохранив предыдущую конфигурацию макета.

Оформив макет, можно перейти к визуализации планшета на экране, нажав кнопку «ОК».

При пропуске номера окна в числовой последовательности (например, 1,2,3, 8,15), номера окон будут скорректированы автоматически.


Сглаживание

Функция предназначена для сглаживания активной кривой (кривых) в окне без создания новой кривой.

Также для сглаживания можно использовать методику "Сглаживание кривых" в технологии "Подготовка данных" и диалог фильтрации.

Функция работает в желтых интервалах.

Для сглаживание нужно открыть панель инструментов сглаживания либо из меню "Вид" -> "Окно сглаживания", либо по кнопке [image] на панели инструментов.

Появится панель инструментов:

В выпадающем списке можно выбрать тип фильтра:

  1. Медианный - в пределах окна сглаживания точки сортируются, средняя по позиции замещает текущую;

  2. Осредняющий - простое среднее в скользящем окне.

Длину окна фильтра можно изменить по кнопке "Парам.".

По кнопке "Фильтр" производится сглаживание активной кривой в активном окне. Если вместо активной кривой выбраны "Все таблицы", производится сглаживание всех кривых.

Следует заметить, что сглаживание производится в пределах желтых интервалов. Если они не заданы, сглаживается вся кривая.

Если результат сглаживания неудовлетворителен, его можно откатить в меню "Редакция" -> "Откатить : Сглаживание".


Сдвиг кривых по времени

Выберите активную кривую или все кривые в одном окне. Затем нажмите кнопку «Подвижка» [image] на панели инструментов Удерживая левую кнопку мыши, перемещайте кривую вдоль оси времен до наилучшего совпадения характерных точек. Указатель мыши изменился. При этом в правой нижней строке планшета (в статусной строке), появится значение величины смещения (пока нажата левая кнопка мыши).


Увязка по реперам

Для увязки одной или нескольких кривых по реперам с деформацией времен выполните следующие действия:

  1. Сделайте одну из кривых активной, выбрав ее название в заголовке одного из полей планшета. Для активной кривой цвет фона заголовка изменится.

  2. Назначьте выбранную кривую базовой, нажав кнопку «Сделать базовой» [image] на панели инструментов. В заголовке окна планшета над строкой главного меню появиться надпись, сообщающая о том, что эта кривая является базовой.

  3. Включите режим установки реперов нажатием кнопку «Репера» [image] . С помощью мышки расставьте в окне с базовой кривой реперные метки по характерным точкам кривой. Соответствующие реперные метки установите в окнах с увязываемыми кривыми. Производится нумерация реперов в каждом окне. Репер можно поставить, точно привязав к точке кривой. Для этого надо перейти в режим «работа с точками кривых» CTRL+SHIFT, позиционироваться на нужную точку, не отжимая CTRl+SHIFT нажать R.

  4. Кнопкой «Увязка по реперам» [image] выполните увязку кривых в окнах, где расставлены реперы.

Если в одном окне находится несколько кривых, то увязка происходит только активных кривых. Если активны все кривые (в заголовке поля выбраны “все таблицы”), то увязка применяется ко всем кривым этого поля.

Удаление репера – встать на репер, указатель мыши изменяет свое изображение, при нажатии правой кнопкой мыши репер удаляется, остальные переименовываются.

Также в меню редакция есть пункты "Убрать все репера" и "Убрать все репера в активном окне".

При двойном нажатии левой кнопки мыши на репере, реперная линия пробрасывается через все поля планшета. Удерживая нажатой левую кнопку мыши, эту линию можно перемещать вдоль оси времен по планшету.

Для того, чтобы закрепить верхнюю и нижнюю границы интервала увязки кривых, установите двойным щелчком левой кнопки мыши реперные линии на всю ширину планшета. Внутри интервала увязки в различных окнах расставьте реперные метки и выполните процедуру увязки. Границы интервала останутся неподвижными, а внутри интервала произойдет деформация кривых по времени в соответствии с установленными реперами. Все реперные метки с одним порядковым номером (но в разных окнах) будут установлены на времени базового репера, слившись в одну линию.

Все изменения по реперам возможно откатить из опции меню Редакция.


Сшивка кривых по времени

При помощи кнопки «Сшивка кривых» [image] можно сшить по глубине кривые в окне. Результирующая кривая будет записана в масштабе активной кривой в том окне, где выполнялась операция. Имеется возможность использовать три варианта сшивки кривых: «без репера», «по одному реперу», «по двум реперам».

Вариант «без репера» применяется в том случае, если кривые не пересекаются по глубине и при сшивке у результирующей кривой в интервале отсутствия значений у исходных кривых будет признак отсутствия данных.

Вариант «по одному реперу» применяется, когда надо сшить две кривые на одном времени. В этом случае помещают две сшиваемые кривые в одно окно. Делают активной ту кривую, которая соответствуют верхнему интервалу сшиваемой кривой, ставят репер на то время, где предполагается сшить кривые, и нажимаем на кнопку «сшивка кривых» [image].

В появившемся окне «Объединение кривых» предлагается имя результирующей кривой, которое при желании можно изменить и выбор удалять ли исходные кривые после объединения или нет. При выборе «Удалять исходные кривые» необходимо учитывать то, что отменить результаты увязки нельзя.

Вариант «по двум реперам» применяется тогда, когда в активную кривую необходимо вставить интервал другой кривой. В этом случае реперами выделяют интервал, который необходимо вставить.


Просмотр и корректировка значений

Просмотр, корректировка и удаление значений

При нажатии и удержании клавиши «Ctrl»+«Shift» в пределах активного поля планшета Вы можете в интерактивном режиме корректировать значения активной кривой. Курсор мыши приобретает вид перекрестья и при нажатии левой кнопки мыши привязывается к узлам кривой. При этом в статусной строке подписываются значения активной кривой.

Путем нажатия клавиш «стрелка вверх» или «стрелка вниз» Вы можете перемещаться по точкам кривой. При этом маркер автоматически приобретает вид для снятия отсчетов с кривой. В окошке внизу окна показывается время нахождения маркера, абсолютное время (согласно заданной дате начала исследований) и значение кривой на данной глубине.

Если Вы, не отжимая клавиши «Ctrl»+«Shift», нажмете и будете удерживать клавиши «стрелка налево» или «стрелка направо», то на глубине нахождения маркера меняется отсчет с кривой. Если редактируемая точка находится внутри желтого интервала, задаваемого с курсором мыши [image], то изменяются все точки внутри желтого интервала с весами, соответствующими удалению точки от краев интервала.

Если Вы, не отжимая клавиши «Ctrl»+«Shift», нажмете на кнопку «D» - то. выбранный отсчет удаляется.

При удержании клавиш «Ctrl»+«Shift» + «D» маркер начинает двигаться вниз. На пути движения удаляются все отсчеты. Программа будет считать, что в пределах удаленного участка отсутствуют данные.

«Ctrl»+«Е» – позволяет присвоить кривой значения в желтых интервалах.

Удалить группу точек можно, просто выделив ее прямоугольником в окне.

Если активная кривая в окне является непрерывной (не параметр цикла), то выпадающее меню будет выглядеть так:

Выбирая опцию "Удалить точки", Вы убираете все отсчеты, попавшие в прямоугольник.

Примечание: все операции по изменению значений и удалению точек можно откатить в меню

"Редакция" -> "Откатить: ...".


Нормализация кривых

При помощи кнопки «Нормализация» [image] возможно провести нормализацию кривой по активной кривой в данном окне.

Изменением горизонтального масштаба выставляется нужное видимое соответствие кривых. После этого нажатие на кнопку «нормировка» и выбор опции «масштабирование» приведет к пересчету значений всех кривых кроме активной в масштаб активной кривой (т.е. все кривые станут в едином масштабе)

Например, имеем в одном окне две кривые давления, и требуется выполнить нормализацию второй кривой по первой.

Совместим вторую кривую c первой в опорных точках (опорных пластах) изменением масштаба кривой (растягивая или сжимая). Сделаем первую кривую активной. Нажмем кнопку нормализации. Вторая кривая будет пересчитана в масштабе первой.


Нормировка по кроссплоту

При помощи кнопки «Нормировка по кроссплоту» [image] можно провести нормализацию кривых по кроссплоту.

Откроется окно опций нормировки:

После этого необходимо выбрать из списка нормируемую кривую и кривую, по которой будет проводиться нормировка (опорную).

В качестве опорных интервалов используются желтые интервалы.

Можно также использовать различные типы связи между кривыми - линейный, билогарифмический либо логарифмирование одной из кривых.

С кривых будут сняты средние значения в опорных интервалах, после чего точки будут нанесены на кроссплот:

Смысл нанесения на кроссплот состоит в том, чтобы наглядно оценить дисперсию зависимости и отфильтровать ненужные точки, если они сильно отстоят от тренда и портят зависимость. это можно сделать, выделив точки с помощью левой кнопки мыши и выбрав опцию "Деактивировать точки". Такие точки не будут участвовать в расчете коэффициентов нормировки.

Опции кроссплота аналогичны обычному кроссплоту: с помощью кнопок панели инструментов можно перезагрузить кроссплот, изменить входные данные, изменить цвет кривой МНК и получить ее формулу, а также при необходимости рассчитать МНК для другого, нелинейного типа связи. Следует отметить, что нормировка будет все равно проводиться по линейному МНК, рассчитываемому по умолчанию. Также планшет можно напечатать на принтер или в графический файл. Опции масштабирования, настройки сетки или размера точки доступны в меню по правому клику на кроссплот.

При нажатии кнопки [image] нормированная кривая выводится в окно с опорной кривой для сравнения.

Кроссплот нормировки является немодальным, то есть можно продолжать работу в программе, не закрывая его окно. Если свернуть окно, оно исчезнет с экрана, но его можно восстановить, выбрав соответствующий пункт в меню "Кроссплоты":


Импорт из Excel и редакция кривых в таблице

Все непрерывные кривые в программе могут быть представлены в табличном виде. В то же время, кривые можно импортировать в программу с помощью этих таблиц.

Вызов таблиц осуществляется с помощью кнопки на основной панели инструментов [image].

Основное окно выглядит так:

Назначение кнопок на панели инструментов:

- удалить все введенные кривые и очищает столбец времен

- предварительные просмотр перед печатью таблицы

- печать таблицы

- копировать выделенный фрагмент

- вставить выделенные фрагмент

- загрузить кривые с планшета

- выгрузить кривые на планшет

- добавить новый столбец

- удалить выделенный столбец

- добавить новую строку

- удалить выделенную строку

Кнопки на панели инструментов также дублируются пунктами меню.

Поскольку в таблице работает вставка, можно выделить нужные столбцы в исходных файлах Excel, а затем вставить их в таблицу.

Для этого предварительно нужно вставить новые столбцы для импортируемых кривых. При создании столбца программа предложит ввести имя новой кривой. По умолчанию имена кривых принимаются номерами столбцов, т. е. 2, 3, 4 и т. д. Чтобы изменить имя кривой, щелкните двойным кликом на заголовок столбца с кривой. Появится диалог, предлагающий ввести новое имя:

Примечание: имена кривых, загруженных с планшета, изменить нельзя.

Загрузить кривые с планшета для редакции или печати можно с помощью соответствующей кнопки.

Появится следующий диалог:

Здесь нужно выбрать в правое окно нужные кривые из левого. Это можно сделать кнопками в левой верхней части или просто двойным кликом на имени кривой в левом окне. Кривые из правого окна можно убрать с помощью кнопки удаления или выделив ненужную кривую и нажав Delete. Также можно управлять порядком расположения столбцов, меняя порядок кривых в правом окне с помощью соответствующих кнопок.

При выгрузке кривых на планшет откроется похожий диалог:

Здесь нужно выбрать кривые, которые нужно выгрузить или перезаписать на планшет. По умолчанию в правое окно выбираются все новые кривые. Все кривые выгружаются в одно новое окно, но с помощью опции внизу диалога можно "разбросать" их в отдельные окна.

Если кривые заданы в относительном времени (то есть, если формат времени не содержит дату), то в нижней части диалога можно задать дату и время начала записи кривых. Если дата начала измерений уже была ранее задана, она появится там по умолчанию. Если же она еще не задана, там появятся прочерки (см. рисунок выше), и начальную дату и время можно задать (можно и пропустить этот шаг, чтобы задать начальное время позже).

Время в файлах Excel может быть в разном формате. Чтобы корректно загрузить файл, необходимо задать формат времени, соответствующий имеющемуся в файле. Управлять форматами можно с помощью дополнительной панели инструментов:

С помощью выпадающего списка выбирается текущий формат представления времени. В соответствии с ним время загружается в таблицу и выгружается из нее. Добавить свой формат можно, выбрав последний пункт выпадающего списка "Добавить...". Также любой формат кроме первого (служебного "Гидратест") можно отредактировать или удалить с помощью соответствующих кнопок. Диалоги редакции формата идентичны используемым при импорте из текстовых файлов.


Фильтрация точек кривой

В контекстном меню активной кривой есть опция "Фильтрация точек...".

При ее выборе открывается диалог:

К кривой можно применить сглаживание, прореживание или комбинированный метод фильтрации.

Сглаживание.

К кривой можно применить несколько типов фильтра:

  1. Осредняющий - простое среднее в скользящем окне;

  2. Линейный - в пределах окна сглаживания исходная кривая приближается прямой;

  3. Параболический - в пределах окна сглаживания исходная кривая приближается параболой;

  4. Экспоненциальный - в пределах окна сглаживания исходная кривая приближается экспонентой;

  5. Медианный - в пределах окна сглаживания точки сортируются. Точка со средней позиции ставится в центр окна.

Длина окна проставляется в соответствующем поле ввода.

Для медианного фильтра также доступна опция рекурсии - это значит, что фильтр будет применяться до тех пор, пока кривая не перестанет меняться. Это служит гарантией того, что после фильтрации на всей кривой любой участок длиной в половину окна фильтра будет монотонным.

Прореживание.

К кривой можно применить несколько типов прореживания:

  1. Каждая N-я точка - на кривой остается только каждая 2-я, 3-я и т. д. точка, в зависимости от заданного шага, остальные выбрасываются;

  2. Линейное - кривая пересчитывается на заданный постоянный шаг (в секундах);

  3. Логарифмическое - в пределах каждого цикла точки расставляются с логарифмическим шагом (вначале часто, затем реже). Числом точек, остающихся на кривой, можно управлять в соответствующем поле ввода.

  4. Удаление ступенек - ступеньки с одинаковыми значениями заменяются на одну точку со средним временем. Замечание: иногда после ступеньки одинаковых значений кривая начинает резко расти или падать. Тогда при удалении этой ступеньки мы сдвинем точку начала роста (падения), что плохо скажется на последующей интерпретации. Опция "Анализ производной" включает режим, в котором на основании анализа производной такие точки не удаляются.

Комбо-метод.

Этот метод можно применять для определенного типа кривых, в которых вследствие небольшой разрешающей способности прибора давление "скачет" с одной ступеньки на другую. В таких кривых медианный фильтр раскладывает точки по ступенькам, а затем ступеньки удаляются, и кривая приобретает заметно лучший вид.

Для каждого типа фильтрации приведено схематическое изображение работы соответствующего фильтра, где синим показана исходная кривая, красным - кривая после фильтрации.

Можно ограничить работу фильтра желтыми интервалами с помощью галочки внизу диалога. Для логарифмического прореживания в этом случае будут прорежены только циклы, полностью попавшие в желтые интервалы.

По кнопке "Фильтр!" кривая фильтруется. Если Вам не нравится результат, его можно откатить к начальному состоянию кривой до входа в диалог с помощью кнопки "Отменить".

По кнопке "Закрыть" изменения сохраняются и диалог закрывается.

Фильтрацию кривой тем не менее можно все равно откатить в меню "Редакция"->"Откатить...".

Для сглаживания можно также использовать методику "Сглаживание кривой" в технологии "Подготовка данных" и функцию сглаживания на панели инструментов.


Циклы

Циклы представляют собой базовый тип интервалов, используемых в программе. С помощью циклов выделяются интервалы времени, отличающиеся особенностями поведения (режимом работы скважины).

Циклы визуализируются в окне колодца циклов:

Выделение цикла можно осуществить двумя способами: табличным и графическим.

Для вызова таблицы циклов нажмите кнопку [image]. Таблица имеет следующий вид:

В таблице слева направо указываются порядковый номер цикла, наименование цикла, конечное время (по относительной и по абсолютной шкале). Можно ввести или скорректировать относительное и абсолютное время каждого цикла. В верхней части окна вводится или корректируется начальное (абсолютное) время первого цикла. Таким образом, Вы можете осуществить сдвиг колонки циклов по оси времени.

По кнопке "Вставить" в левом нижнем углу поля Вы можете вставить новый цикл выше любого отмеченного Вами левым кликом (активного) цикла. Если активный цикл не выделен, цикл вставляется на первую позицию. По кнопке "Удалить" активный цикл удаляется.

Любому новому циклу по умолчанию присваивается тип «не ясно».

Чтобы изменить тип цикла, кликните на столбец "Цикл" в строчке выбранного Вами цикла и нажмите на появившуюся кнопку [image].

В появившемся выпадающем списке выберите новый тип цикла:

Для графического ввода циклов, выбрав тип курсора для установления границы [image], с помощью левой кнопки мыши установите границы цикла, нажимая левой кнопкой мыши непосредственно в окне колодца циклов. При отсутствии на планшете границ циклов время начала первого цикла по умолчанию устанавливается равным нулю. Границы цикла можно корректировать, просто перетаскивая их с одного времени на другое в окне колодца циклов.

Тип устанавливаемого цикла выбирается в окне выбора цикла:

При этом воспользуйтесь текстовым списком циклов, появляющимся по нажатию кнопки:

Для корректировки типа выбранного цикла (по умолчанию – «фонтанирование, пуск») с помощью мыши выберите нужный тип в окне выбора цикла, активизируйте кнопку заливки [image] и нажмите левой кнопкой мыши на изменяемого цикл в окне колодца циклов.

Выделение Активного (кроссплотного, зеленого) цикла.

Цикл выделяется по двойному нажатию левой клавиши мыши или с помощью стандартного меню, которое вызывается по нажатию правой кнопки мыши:

При назначении другого цикла двойным кликом выделение предшествующего автоматически отменяется; при использовании опции "Добавить к активному" выделяются все смежные циклы от текущего активного до выбранного - эта опция также работает при левом клике на цикл с нажатой клавишей Shift.

Если выделено несколько активных (зеленых) циклов, они считаются методиками как один общий цикл.

О выделении циклов желтыми интервалами см. раздел Сервисные средства -> Желтые интервалы.

О вводе параметров цикла см. раздел Работа с циклами -> Параметры цикла.


Параметры цикла

Циклы работы скважины могут характеризоваться параметрами, которые не меняются на всем протяжении цикла. Такими параметрами могут быть, например, дебит или общее количество добытой жидкости.

Многие расчетные методики программы, в том числе по обработке КВД или данных, полученных во время свабирования, требуют на вход такие параметры.

Для ввода таких параметров предназначен диалог, вызываемый по кнопке "Задание циклов" [image] на главной панели инструментов.

Параметры цикла отображаются как столбцы таблицы справа, они отмечены желтым цветом.

Вставить параметр цикла можно с помощью кнопки "Вставить" справа внизу. Там же расположены кнопки для просмотра свойств и удаления параметра. Выделить параметр для просмотра свойств или удаления можно, кликнув по заголовку соответствующего столбца.

Диалог свойств параметра выглядит следующим образом:

Здесь можно задать формат чисел столбца, а также задать имя и единицы измерения параметра. При выборе стандартного имени имя и единицы измерения заполняются автоматически характерными значениями.

Значения параметра для каждого цикла могут быть отредактированы непосредственно в таблице. Кроме того, можно приблизительно выставить значения параметра прямо на планшете: при подведении курсора к "ступеньке" курсор сменится и с его помощью можно перетащить значение параметра.


Свойства линейки времени

Линейка времени может быть отображена в двух режимах:

режим относительного времени:

и режим абсолютного времени:

Переключение между режимами осуществляется с помощью контекстного меню, которое открывается по правому клику в окне линейки:

Примечание: режим абсолютного времени можно включить только если задана дата начала исследования.


Свойства кривой

По правой кнопке мыши в окне открываем в меню опцию «Свойства кривой», получаем в окне «Свойства» подробную информацию об активной кривой (активная кривая переключается в заголовке окна): название, атрибуты, заливку, интервал вывода, а также параметры для печати. В окне «Свойства» имеется 4 закладки: «основные», «линии», «точки», «при печати».

В закладке «основные» можно:

  • установить пределы интервала для вывода кривой на экран (горизонтальный масштаб);

  • «Не рисовать» – кривая не будет видна при печати;

  • «Рисовать без дырок» - если в непрерывной кривой имеется разрыв (например, если удалены некоторые значения), то при помощи этой опции, кривая будет отрисована без разрывов (крайние точки разрыва соединяются прямой линией);

  • установить логарифмический масштаб для кривой;

  • определить число знаков после запятой.

Так же в закладке «основные» сохраняется имя исходного файла (LAS или другой).

В закладке «линии» можно выбрать тип, цвет и толщину линии.

Примечание: тип линии отличный от сплошной линии (пунктир и т.д.) отображается только при толщине – 1, если толщина линии больше 1, тогда любой тип линии рисуется сплошной.

В закладке «точки» можно представить кривые в виде набора точек.

Для дискретных данных (керн) или для непрерывных кривых, можно выбрать тип условного обозначения – треугольник, окружность или квадрат, указать нужный цвет, размер и заливку элементов, если толщину линии при этом выбрать равной нулю, то на экране появится кривая в виде точек.

В закладке «при печати» имеются следующие возможности:

  • «Печатать имя кривой» – позволяет задать имя кривой для печати. Если не надо печатать имя кривой в списке кривых данного поля, то эту опцию делают не активной;

  • «Использовать горизонтальный масштаб» – применяется для задания горизонтального масштаба при отрисовке кривой на планшете, необходимо задать количество единиц на см.

  • задать тип вывода:

  • «Без переноса»

  • «C переносом» - применяется при отрисовке кривой на планшете печати, если кривая не умещается в данной колонке. Невидимая правая часть кривой будет показана с левой границы в масштабе кривой.

  • «Три масштаба» - похож на предыдущий, но «зашкаливающая» часть кривой будет выводиться уже в более мелком кратном масштабе и так до трех раз зашкаливания.

В закладке «дополнительные» можно задать:

  • глубину точки замера

  • единицы измерения

  • стандартное имя

  • метод

  • тип прибора

  • способ работы

  • комментарий к кривой

Кроме того, можно пометить, является ли кривая расчетной.

Большинство этих параметров используется для печати в заключение и передачи в Базу Данных.


Свойства окна

По правой кнопке мыши в окне открываем в меню опцию «Свойства окна»

Эта опция дает возможность редактирования свойства окна и заливки кривых в данном поле.

Если активизировать опцию «Не печатать заливки в условных обозначениях», то заливки, которые использовались в этом окне при печати, не будут отображены в условных обозначениях.

В поле «Сетка» задаются параметры рисования линий сетки.

Переключатели "Не печатать горизонтальную" и "Не печатать вертикальную" задают настройки рисования горизонтальных и вертикальных линий.

«Число вертикальных линий» – это число вертикальных линий сетки в данном окне, не считая линий на границах окна, так для 10 градаций число вертикальных линий – 9, для 20 - 19.

Если в поле «Имя для печати» написать название, то оно будет использовано для подписи данного окна при печати.

«Заливки»

Выбираем правую и левую границы заливки. Это можно сделать, выбрав из предложенного списка (по правой кнопке справа в окошке) либо кривую, либо окно (границу данного окна на планшете), либо определив конкретное число. По двойному щелчку мыши в окошке Заливка, выбираем фон, тон заливки и кисть.

Имя заливки определит имя в условных обозначениях.

Если в одном окне заданы заливки для нескольких кривых, то необходимо обратить внимание на порядок расположения строк, описывающих эти заливки.

Скопировать строчку можно, выделив ее стрелкой по левой кнопке мыши, нажав клавиши Ctrl+С, затем, пометив строку, в которую вставляем, выполнить команду Ctrl+V. Удалить строчку можно клавишей Delete, предварительно выделив ее.


Визуализация кривых в окне планшета

Операции над кривыми в окне планшета

По правой кнопке мыши в окне кривых открывается меню:

Пункты этого меню относятся к активной кривой (к той, которая выбрана в выпадающем списке в заголовке окна).

Свойства кривой – см. Свойства кривой.

Свойства окна – см. Свойства окна.

От мин. до макс. кривой – эта опция позволяет оптимально расположить кривую в окне. В этом случае точки шкалы масштаба, соответствующие краям окна, в точности соответствуют максимуму и минимуму диапазона изменения значений кривой.

Единый масштаб - все кривые в данном поле перерисовываются в масштабе активной кривой.

Поднять кривую - эта опция означает нарисовать активную кривую поверх других.

Предыдущий масштаб - эта опция позволяет перейти к предыдущему масштабу после ZOOM'a в окне. Можно откатить всю историю изменения масштабов до начального. Это может быть удобно при точном назначении границ циклов, когда нужно сначала сильно приблизить интересующий участок, а затем вернуть предыдущий масштаб.

Убрать в нулевое окно – возможность не визуализировать кривую, поместить ее в нулевое окно.

Достать из нулевого окна – возвратить на планшет кривую, ранее убранную в нулевое окно.

Восстановить кривые можно в данное окно, в новое окно, либо удалить их.

Непрерывную в параметр цикла - эта опция превращает ступенчатую кривую из входного файла (которую программа все равно воспринимает как непрерывную) в параметр цикла. При этом автоматически расставляются границы циклов на точках, где кривая меняет значение.

Пересчитать в других единицах измерения - опция позволяет пересчитать значения кривой, переведя ее в другие единицы измерения той же физической величины.

Фильтрация точек - вызывает диалог фильтрации точек активной кривой.

Пересчет давления - (только для непрерывных кривых с единицами давления) открывается дополнительное меню:

Выбор пунктов этого меню вызывает соответствующую методику пересчета для активной кривой.

Удалить кривую - опция позволяет удалить из планшета активную кривую.

Статистика

По правой кнопке мыши для активной кривой можно получить следующие данные: начальное и конечное времена, минимальное и максимальное значения, времена минимума и максимума, среднее значение и среднеквадратическое отклонение.

При наличии выделенных «желтых интервалов» становится активной кнопка «Использовать желтые интервалы», при ее активизации статистические параметры определяются для выделенных интервалов.

При нажатии кнопки «Гистограмма» на экран выводится распределение значений активной кривой.

По кнопке «Настройка» получаем параметры гистограммы

Эти параметры можно изменить и получить новую статистику. Гистограмму можно вывести на печать или сохранить изображение в файл.


Блок PVT свойств

Блок PVT-свойств флюидов и твердой фазы

Блок предназначен для расчета PVT свойств по корреляциям или задания их вручную.

Заданные значения и алгоритмы будут использоваться при интерпретации во всей программе.

Для ввода данных и выбора алгоритмов расчета свойств флюидов воспользуйтесь кнопкой [image] на основной панели инструментов или на панели инструментов кроссплота при расчете какой-либо методики. Откроется окно, содержащее несколько закладок:

Свойства газа:

Здесь в верхней части задаются исходные данные для расчета свойств.

Можно задать либо состав газа полностью, либо относительную плотность по воздуху и содержание компонент, наиболее критично сказывающихся на свойствах.

Также при необходимости можно задать заранее рассчитанные критические свойства газа.

В нижней части задаются алгоритмы расчета свойств газа.

Некоторые алгоритмы предполагают, что известен полный состав газа, и, если он не задан, выбрать их нельзя. Суффикс [Инструкция] означает, что данный алгоритм предлагается в инструкции по комплексному исследованию газовых пластов и скважин под редакцией Зотова и Алиева.

Флаг "Выбрать рекомендованные алгоритмы" убирает возможность выбора алгоритма. В этом случае будут автоматически выбираться наиболее точные алгоритмы для представленных исходных данных.

Кнопка "Печать в XLS" выдает на отдельную страницу заключения Excel отчет по исходным данным и алгоритмам, используемым при расчете PVT-свойств газа.

Проверить расчет свойств можно в методиках пакета "PVT свойства газа".

Ниже дан список алгоритмов с условиями применения и ссылками на источник.

1. Если критические параметры не заданы пользователем, можно выбрать следующие алгоритмы:

  • Графический способ [Инструкция] [1]

  • Правило Кея [Инструкция] [1] (При содержании менее 10% высококипящих фракций и неУВ компонентов)

  • Правило Иоффе, Стюарда, Буркхарда и Ву модиф. по Сэттеру [Инструкция] [1]

  • Правило Иоффе, Стюарда, Буркхарда и Ву [2]

  • Корреляция Хенкинсона, Томаса и Филлипса [2] (При содержании менее 5% кислых компонентов и азота)

  • Корреляция Латонова и Гурвича [2] (При содержании менее 5% кислых компонентов и азота)

2. Вязкость при атмосферном давлении можно вычислить по следующим алгоритмам:

  • Графический способ Карра [Инструкция] [1]

  • Корреляция Ли и Икина [2]

  • Формула Хернинга и Ципперера [Инструкция] [1]

3. Вязкость при текущем давлении можно вычислить по следующим алгоритмам:

  • Графический способ Карра [Инструкция] [1]

  • Корреляция Старлинга и Эллингтона [2]

4. Коэффициент сверхсжимаемости можно вычислить по следующим алгоритмам:

  • Графический способ Брауна [Инструкция] [1] (При содержании менее 10% высококипящих фракций и неУВ компонентов)

  • Уравнение Редлиха-Квонга [Инструкция] [1]

  • Формула и графики Питцера [Инструкция] [1]

  • Уравнение Редлиха-Квонга модиф. по Аккерману [Инструкция] [1, 3]

  • Уравнение Соаве-Редлиха-Квонга [4]

  • Уравнение Пенга-Робинсона [4]

Литературные источники:

1. Инструкция по комплексному исследованию газовых и газоконденсатных пластов и скважин. Под ред. Г.А.Зотова, З.С.Алиева. Москва, 1980 г.

2. Гуревич Г.Р., Брусиловский А.И. Справочное пособие по расчету фазового состояния и свойств газоконденсатных смесей. Москва, 1984 г.

3. Otto Redlich, F.J.Ackerman... Thermodynamics of solutions. Equation of state and vapor pressure. Ind. Eng. Chem. Fundamen, 1965, 4 (4), pp 369–373.

4. А. И. Брусиловский. Фазовые превращения при разработке месторождений нефти и газа. Москва, 2002 г.

Свойства нефти, воды, твердой фазы:

Задание или расчет свойств нефти, воды и твердой фазы идет на трех других закладках, устроенных схожим образом.

Здесь в верхней части задаются исходные данные для расчета свойств.

В числе прочих - параметр "Пластовое давление для расчета PVT свойств". Он определяет, для какого давления определяются свойства фаз.

В нижней части задаются алгоритмы расчета свойств.

Флаг или опция "Задается вручную" позволяет задать свойство непосредственно числом в верхней таблице.

Ниже в блоке "Результаты" можно посмотреть, какие значения примут свойства. Чтобы пересчитать значения после смены алгоритма или изменения исходных данных, нажмите кнопку "Применить и пересчитать".

Кнопка "Печать в XLS" выдает на отдельную страницу заключения Excel отчет по исходным данным и алгоритмам, используемым при расчете PVT-свойств, а также результаты расчета.

Проверить расчет свойств можно в методиках пакета "PVT свойства нефти" или "PVT свойства воды".


Функциональные возможности кроссплота методик

Кроссплот предназначен для визуализации кривых различных зависимостей при интерпретации данных ГДИС.

С помощью кроссплота уточняются расчетные интервалы, отбраковываются выбросы, при этом происходит онлайн пересчет результирующих параметров. Через окна кроссплота рассчитанные параметры попадают в рабочий набор данных. Вид кроссплота может быть настроен, изображения и таблицы параметров могут быть сохранены в файл заключения Excel.

После нажатия кнопки "Расчет" в окне выбора методики, появится кроссплот (на рисунке изображен кроссплот метода индикаторной):

В заголовке кроссплота можно увидеть название методики.

На основной панели инструментов доступны следующие опции:

- входные параметры текущей методики,

- рассчитанные по текущей методике параметры,

- ввод исходных данных и выбор алгоритмов расчета PVT-свойств флюида,

- изменение окна сглаживания производной давления (для методик Предварительный просмотр в Log-LOG масштабе и КД: нестабильный расход, однородный пласт),

- совмещение экспериментальной и расчетной кривой по значениям ФЕС (для методик КД: нестабильный расход, однородный пласт и Гидропрослушивание: произвольное изменение дебита),

- изменение размера шрифтов на итоговой картинке,

- печать изображения на принтер,

- печать изображения в файл,

- запись изображения в файл заключения Excel.

В кроссплоте осуществляется расчет МНК и совмещения. Для уточнения границ, в которых рассчитывается МНК и проводится совмещение, можно воспользоваться Желтым интервалом кроссплота. Для изменения его границ подведите указатель мыши к границе. Курсор изменится на такой: . После этого просто перетащите границу с помощью левой кнопки мыши. Точки, не попавшие в желтый интервал, не участвуют в расчете МНК и совмещения.

Также можно отбраковать точку или группу точек, выделив их область левой кнопкой мыши и выбрав пункт "Деактивировать точки":

Изображение точек изменится, и они будут также выключены из расчета. Включить их обратно в расчет можно, повторив эту операцию и выбрав пункт меню "Активировать точки".

В окне входных параметров

можно ввести значения параметров для текущей методики.

С помощью кнопки "Печать в XLS" можно добавить таблицу входных параметров в файл заключения Excel.

В окне выходных параметров

можно просмотреть рассчитанные значения параметров и записать их в рабочий набор данных либо все сразу (с помощью кнопки "Все выходные в РНД"), либо по отдельности, выделяя параметр и нажимая кнопку "В РНД".

Если значение параметра выделено красным, значит, его значение лежит вне допустимых в РНД пределов и оно не будет записано в РНД. Предупреждение об этом будет отображено при попытке его записи.

Таблицу выходных параметров также можно напечатать в файл заключения Excel при помощи кнопки "Сохранить в XLS".

Также в заключение можно добавить таблицу состава газа в виде круговой диаграммы, кнопка для этого присутствует на форме ввода состава газа.

В методиках КД: нестабильный расход, однородный пласт и Гидропрослушивание: произвольное изменение дебита предусмотрено совмещение экспериментальной и расчетной кривой давления. При нажатии кнопки "Совмещение" на кроссплоте появляется расчетная кривая и открывается диалог подбора наилучшего совмещения:

В окнах напротив параметров отображаются текущее значение, минимальная и максимальная граница поиска, число градаций и опция - производить ли подбор по данному параметру. Если ее отключить, значение параметра будет оставаться неизменным. В окне СКО показано значение средне-квадратичного отклонения экспериментальной и расчетной кривой. Опция "Подбирать немедленно" позволяет видеть изменения расчетной кривой на картинке сразу при изменении значения параметра. Значения можно ввести, можно "поиграть" ими, используя кнопки Вверх и Вниз около окна ввода.

Кнопка "Подбор" запускает итерации поиска лучшего совмещения. Если процесс достаточно долгий, на экране появится Линейка прогресса и отображением текущего процента выполнения операции. Кнопка "Удалить" удаляет расчетную кривую с кроссплота. При этом подобранные параметры сохранят свои значения и останутся доступны в окне выходных параметров.

В методике КД: линейные анаморфозы можно просмотреть кроссплот в различных масштабах, от масштаба также зависят методы расчета искомых параметров. Для смены масштаба в этой методике предусмотрена отдельная панель масштабов:

Названия масштабов ясны из всплывающих подсказок.

График можно настроить по своему усмотрению, выбрав нужный масштаб с помощью ZOOM'а левой кнопкой мыши. Кроме того, по правой кнопке мыши доступно меню со следующими опциями:

Свойства активной кривой... - позволяет редактировать цвет, толщину линии и размеры, форму и цвет точек активной кривой. Активная кривая выделяется прямоугольником в окне легенды справа. Сделать кривую активной можно, выбрав ее в окне легенды, либо кликнув на кривую в основном окне.

Показывать активную кривую - включает/отключает отображение активной кривой.

Предыдущий масштаб - откатывает изменение масштаба к состоянию до последнего ZOOM'а.

Исходный масштаб - возвращает масштаб к исходному, полностью отображая все кривые.

Активировать все точки - возвращает в расчет все точки на кроссплоте.

Активировать все точки активной кривой - возвращает в расчет все точки активной кривой.

Деактивировать все точки активной кривой - исключает из расчета все точки активной кривой.

Вставить левый предел обработки - устанавливает левую границу Желтого интервала кроссплота (см. выше) на точку правого клика.

Вставить правый предел обработки - устанавливает правую границу Желтого интервала кроссплота (см. выше) на точку правого клика.

Горизонтальная сетка, Вертикальная сетка - включают/отключают отображение соответствующей масштабной сетки.

Копировать в буфер - копируют в буфер обмена Windows изображение кроссплота для дальнейшей вставки в любой файл заключения, отчета и т. д.

При движении курсора вдоль кривых в строке состояния подписываются координаты ближайших к курсору точек кривых, а также шифр активной кривой.


Пользовательские методики

Нажмите кнопку «Калькулятор кривых» [image] и вы откроете окно «Редактора формул». С помощью Редактора формул можно выполнить любые алгебраические действия над кривыми и рассчитать непрерывную кривую или новый параметр цикла.

Слева в окне «Редактор формул» располагается окно со списком имеющихся на планшете кривых и параметров цикла. Слева от имени каждой кривой указан номер окна, справа в скобках – порядковый номер кривой. Перенести кривую из окна списка в правое окно Редактора формул можно двойным щелчком мыши на имени кривой, либо набрав ее символьное имя в правом окне «Редактора формул».

Символьное имя таблицы в Редакторе формул обозначается буквой t и порядковым номером. Одна из таблиц, времена которой будут использоваться в расчетах как базовые, должна иметь обозначение tb. Это необходимо для того, чтобы можно было одновременно использовать в расчетах несколько таблиц, имеющих различный шаг по времени или неравномерную последовательность времен.

Нажав на кнопку «Сохранить», формулы для расчета можно сохранить в файле типа - *.f . По кнопке «Открыть» можно загрузить нужный файл с формулами.

После расчета в новом окне появляется кривая или параметр цикла с именем, заданным пользователем. Если одноименная кривая существовала, она будет перезаписана в том окне, где находилась.

Если базовой таблицей при расчете была непрерывная, создается непрерывная кривая, если параметр цикла – создается параметр цикла. Базовая кривая может не быть явно задана, то есть ни у одной из таблиц не будет обозначения tb. В этом случае базовой назначается первая из упоминаемых кривых. Это значит, что если t2 – параметр цикла, а t3 – кривая, то формула t2 + t3 даст параметр цикла, а t3 + t2 даст кривую.

Параметр цикла создается без стандартного имени и единиц измерения. Эти свойства, если необходимо, можно заполнить в диалоге по кнопке «Макет» [image].

Создание формул осуществляется с помощью специального языка программирования. Результат описывается переменной result, с использованием определенных переменных, такие как:

• time – время в секундах для текущей точки.

Его можно использовать, например, для дифференциации расчета на разных временах. Например:

IF time > 5030 THEN

A = 5

ELSE

A = 6

ENDIF

Если время в таком виде (5030) использовать неудобно, можно воспользоваться оператором преобразования времени из общего формата в секунды. Он записывается следующим образом:

TM(h:m:s), где h, m, s – значения часов, минут и секунд. То есть, оператор TM(2:31:04) даст на выходе значение 9064. Тогда можно записать условие следующим образом: IF time > TM(2:31:04) THEN…

• t1, t3… – значения используемых кривых на текущем времени (цифра – это идентификатор кривой). Символом «b» необходимо обозначить имя кривой, с которой будут браться времена, например, tb5.

• переменные, заданные пользователем. Для этого надо присвоить вводимой переменной некоторое значение, например, Pi=3.14.

Поддерживаются русские имена переменных.

С цифрами и переменными можно производить следующие действия:

+ - / * -стандартные арифметические операции;

^ -возведение в степень;

% -взятие остатка от деления;

SIN, COS, TAN, SQR, LN, LG, EXP - стандартные алгебраические операции;

< ,<= , > , >= , = , <> -логические операции.

Можно использовать круглые скобки.

Специальные функции:

MIN, MAX, AVE, DISP - для вычисления соответственно минимального, максимального, среднего и средне-квадратичного значения кривой.

Операторы языка:

IF…[AND, OR]…THEN…[ELSE]…ENDIF - оператор сложного условия;

метки и GOTO - оператор безусловного перехода к метке;

REM - комментарий;

END -оператор окончания программы

(обязателен в конце программы).

Обязательные элементы программы:

- имя кривой, с которой берутся времена;

- переменная result;

- оператор END на последней строчке.


Задание параметров методики

В программе есть несколько комплексов (пакетов) методик, объединенных по схожести решаемых задач. Чтобы вызвать ту или иную методику, нужно выбрать соответствующий пакет из выпадающего списка, появляющегося на панели инструментов при нажатии кнопки [image].

Затем нужно нажать на кнопку "Параметры" рядом с выпадающим списком. Появится диалог задания параметров методики:

Здесь необходимо отметить нужную методику галочкой в столбце "Считать". Галочка в столбце "Выводить" появится автоматически.

Номер окна, куда будут выводиться кривые, автоматически изменится на следующее новое окно.

С помощью кнопки "Новые окна" можно принудительно задать для методики номер нового окна (это может пригодиться в ситуации повторного расчета, если Вы хотите не пересчитать имеющуюся кривую, а получить новую).

Можно задать номер окна вручную, впечатав его в столбце "Окно". Если в заданном окне уже есть кривая, рассчитанная в этой методике, она будет вновь пересчитана.

В нижней части окна находятся параметры методики. Здесь нужно выбрать исходные кривые и задать численные параметры и различные опции методики. Параметры можно сохранить и загрузить, для этого предусмотрены соответствующие кнопки. Впрочем, параметры после расчета методики будут автоматически сохранены, и, если сохранить файл, а затем вновь открыть, параметры методик также сохранятся. Следует отметить, что одинаковые параметры во всех методиках имеют одно значение, то есть, изменив, например, коэффициент обводненности при расчете одной из методик, при расчете других менять его уже не нужно - везде подставится новое значение.

На диалоге также есть кнопка "Справка", которая вызывает раздел помощи об этой методике.

Кроме того, можно управлять выводом заключения по методике в протоколы - текстовый и Excel. Для этого нужно нажать соответствующие кнопки перед расчетом методики.

Расчет запускается по кнопке "Расчет". Программа проверяет допустимость введенных параметров, номеров окон, а затем выдает результирующие кривые в указанные окна.

Есть группа методик, которые не рассчитывают кривые, а определяют некоторые параметры по кросс-плотам. Для них задание параметров ничем не отличается, кроме того, что не нужно задавать номер окна:


Рабочий набор данных

Рабочий набор данных (РНД) служит для хранения различной информации о скважине.

Многие параметры РНД используются расчетными методиками, присвоить им значения можно непосредственно в таблицах ввода параметров для методик.

Некоторые параметры (название месторождения, компании и т.д.) используются только при печати в заключение.

Параметры альтитуд, магнитного склонения и сближения меридиан используются при расчете инклинометрии.

Здесь же хранятся параметры интерпретации, полученные при расчетах в методиках программы. В версии с Базой Данных эти параметры могут быть экспортированы в базу.

Окно РНД открывается по клавише [image] и имеет следующий вид.

Слева находятся разделы, справа - таблицы с параметрами.

Некоторые поля в разделах РНД имеют справочники. Справочник может редактироваться. Команда «Правка > Изменить справочник» открывает таблицу со всеми доступными справочниками.

В справочнике выбирается соответствующий параметр для редактирования. Нажатие кнопки со стрелкой открывает таблицу редакции выбранного справочника.

В графе KOD вводится код (любое уникальное цифровое или буквенное обозначение), в графе NAME – соответствующее значение или название. В таблице работают стандартные функции выбора и удаления строки. Новую строку в список можно добавить, начав заполнение строки с символом *.

Вызвать таблицу для редакции справочника можно также, нажав любую клавишу в строке списочного параметра.

Если при выборе какого-либо раздела РНД окно пустое и не содержит никакой информации,

то для добавления строк в таблицу нужно воспользоваться кнопкой [image] на панели инструментов. Предварительно необходимо кликнуть на пустое окно справа, чтобы эта кнопка активировалась.


Таблица инклинометрии

Для ввода и анализа данных инклинометрии воспользуйтесь кнопкой [image] на основной панели инструментов. Откроется окно таблицы инклинометрии:

Возможны два режима использования инклинометрии: штатный и экспрессный.

В штатном режиме Вы должны ввести в таблицу значения кабельной глубины (в метрах), угла и магнитного азимута (в градусах).

Это стандартный набор исходной информации, предоставляемой геофизической службой. После ввода перечисленных данных и нажатия клавиши расчет [image] программа автоматически рассчитывает остальные колонки таблицы и Вам становятся доступными средства графического просмотра результатов:

Окно проекции инклинометрии:

Окно 3D изображения:

Назначение кнопок панелей инструментов ясно из всплывающих подсказок.

В экспрессном режиме нужно ввести только таблицу глубин и соответствующие значения абсолютных отметок. Этой информации вполне достаточно для работы всех без исключения интерпретационных методик программы, использующих данные инклинометрии.

Возможен ручной и полуавтоматический ввод результатов инклинометрии. При ручном вводе Вы должны поочередно ввести нужное число глубин и соответствующих отсчетов угла. При полуавтоматическом вводе Вы можете экспортировать таблицу результатов, предварительно подготовленную в одной из стандартных электронных таблиц (например, в «EXСEL»). Для этого можно воспользоваться стандартными командами Windows: «Ctrl+C» - копирование, «Ctrl+V» - вставка. Удаление значений в таблице инклинометрии, производится по клавише «Del».

В версии с базой данных информация инклинометрии автоматически подгружается в рабочий набор из таблиц базы. В базу данных инклинометрия загружается в автоматизированном режиме с помощью специализированных программ импорта и конвертации.


Таблица предыстории

Для ввода данных о предыстории воспользуйтесь кнопкой [image] на основной панели инструментов. Откроется окно таблицы предыстории:

Показанная на рисунке предыстория для водонефтяной скважины говорит о том, что три месяца до начала цикла обработки КВД (или до начала первого выделенного желтым интервалом цикла, если они есть) скважина работала с дебитом 100 м3/сут, а до этого 2 месяца работала с дебитом 120 м3/сут.

Единицу времени, используемую при задании предыстории, можно менять:

Коэффициент обводненности определяет, какая часть дебита жидкости была водой. Ноль означает, что скважина работает чистой нефтью, единица - чистой водой.


Желтые интервалы

Интервалы планшетной обработки (так называемые Желтые интервалы) используются в программе для уточнения области обработки. Большинство методик так или иначе учитывают расстановку этих интервалов, например, методики Сглаживание, Функциональные преобразования и т. д. отработают только в выделенном интервале.

Если интервалы не заданы, расчет ведется по всему диапазону времен. Исключением являются случаи, когда методика требует обязательно выделить определенные циклы (например, Метод индикаторной).

Способ учета желтых интервалов смотрите в описании конкретной методики.

Кроме того, желтые интервалы принимаются как опорные при Нормировке по опорным интервалам.

Желтыми интервалами могут быть выделены как определенные циклы колодца циклов, так и произвольные диапазоны времен.

Для того, чтобы выделить цикл, сделайте активным окно колодца циклов, кликнув на него, а затем, удерживая Ctrl, кликните на цикл, который нужно выделить:

Кликните так же еще раз, чтобы отменить выделение. Эти опции (установить/снять выделение цикла) также доступны по правому щелчку на цикл:

Опция "Установить выделение однотипных циклов" позволяет выделить одновременно все циклы, имеющие тот же тип (см. раздел Циклы), что и выбранный. При этом с остальных циклов выделение снимается.

Когда цикл выделен, изменение его границ приводит к автоматическому сдвигу желтого интервала к новым границам цикла.

Кроме того, желтыми интервалами можно отметить произвольный диапазон времен.

Для этого сделайте активным любое окно с кривыми, щелкнув на него, и выберите на панели курсоров курсор выделения интервалов [image]. Курсор изменит свой вид - активизируется режим выделения интервалов.

Далее, удерживая нажатой левую кнопку мыши, выделите нужные диапазоны времен на планшете. Чтобы удалить интервал, кликните на нем правой кнопкой в режиме выделения интервалов. Удалить одновременно все выделенные интервалы можно, используя в меню "Редакция" опцию "Отменить все интервалы". Чтобы вернуться в обычный режим, выберите на панели курсоров обычный курсор [image].

Следует заметить, что, если при выделении произвольного диапазона времен были целиком выделены некоторые циклы, они считаются выделенными так же, как и в случае их отдельного выделения (см. выше). Это означает, что необязательно выделять по очереди несколько смежных циклов - достаточно выделить диапазон времен, захватывающий их все.


Протоколы обработки

В программе предусмотрено два вида фиксации результатов обработки - текстовый протокол и заключение Excel.

Текстовый протокол

Текстовый протокол представляет собой файл формата txt, в который добавляется информация по расчетным методикам. Для добавления протокола работы методики в файл нажмите на кнопку "Текст" в рубрике "Сохранять в протокол" в окне расчета методики:

Какие из методик выдают протокол - смотрите в справке к методикам.

Файл протокола можно вывести на экран одновременно с программой с помощью пункта меню:

Кроме того, по пункту меню:

открывается следующий диалог:

Здесь можно выбрать другой путь для протокола ("Другой"), отобразить его в окне на экране ("Показать") и очистить текущий файл ("Очистить").

Заключение Excel

Все методики, выдающие текстовый протокол, также могут выдавать его в файл Excel. Для этого нажмите кнопку "Excel" в рубрике "Сохранять в протокол" в окне расчета методики:

Если Вы впервые за сеанс работы выдаете что-то в файл Excel, будет предложено выбрать путь и имя файла, в который будет производиться запись. Можно заранее выбрать или сменить этот путь с помощью пункта меню:

При этом протокол по новому пути будет пуст.

Кроссплотные методики выдают заключение на третью страницу ("Протоколы кроссплотных методик"), остальные - на вторую ("Протоколы расчетных методик").

Шаблон заключения Excel находится в папке mdb в папке программы Гидра. Шаблон можно изменить, поместив в верхнюю часть логотип, название и сведения об организации, в этом случае все следующие заключения будут уже с новым шаблоном. Однако не следует менять количество, расположение листов и порядок параметров в таблице на первом листе..

Ручной набор заключения Excel.

Кроме добавления протоколов методик, заключение Excel можно составлять вручную, добавляя необходимые изображения и таблицы. Например, методика "Модель" заполняет первую страницу заключения с помощью различных опций печати в заключение Excel.

В других кроссплотных методиках также есть опции печати изображений и таблиц параметров в заключение - они попадут на третью страницу ("Протоколы кроссплотных методик").

Также можно выводить в заключение Excel информацию по расчету PVT-свойств флюидов, пользуясь кнопками на закладках соответствующего диалога.


Экспорт в LAS

Кривые, обработанные или рассчитанные в программе, можно экспортировать в общепризнанном формате LAS для вывода или обработки в других программах.

Для этого в меню "Файл" есть два пункта:

Экспорт в LAS

Экспорт в LAS всех таблиц

Первый пункт экспортирует только активную кривую (кривые), второй - все кривые с планшета. При выборе этих пунктов выводится диалог.

Здесь можно выбрать с каких времен брать точки на экспорт - с одной из экспортируемых кривых или с некоторым равным шагом. Заметим, что если в числе экспортируемых кривых есть параметры цикла, нельзя провести экспорт с их глубин. Поэтому необходимо, чтобы в числе экспортируемых была хотя бы одна непрерывная кривая.

Также в диалоге можно выбрать начальный и конечный временные пределы экспорта.


Помощь

В программе предусмотрено несколько видов доступа к справочной системе.

1. Через кнопку F1 в главном окне или пункт меню Помощь -> Справка открывается справочная система на окне приветствия.

2. По кнопке F1 в основных окнах программы открывается раздел с описанием функций текущего окна.

3. По кнопке "Справка" в диалоге задания параметров методики открывается раздел с описанием выбранной методики.

Кроме того, в программе предусмотрен механизм "Подсказок дня" по полезным функциям. Его можно отключить или включить заново по пункту меню Помощь -> Подсказка дня.

В окне Помощь -> О программе можно узнать номер версии программы и название организации, куда она поставлена.


ГидраТест.

Добро пожаловать в справочную систему по программе "ГидраТест"!

"ГидраТест" является компонентом компьютерной системы "Камертон" и предназначен для количественной обработки результатов гидродинамических исследований нефтяных и газовых скважин.

Дополнительную информацию и контакты смотрите на сайте www.getek.ru


Дебит по данным промысла

Методика просто подставляет заданное значение дебита в выходную кривую в отмеченных интервалах. Ее как правило используют последней, когда для других участков кривой дебит рассчитан по другим методикам дебита.

Методика работает в желтых интервалах.

Входные данные:

Параметры:

  • Дебит по данным промысла

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит по ДИКТ

Методика рассчитывает дебит по данным диафрагменного измерителя критического течения (ДИКТ). Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Буферное давление (Pb)

  • Диаметр штуцера (если переменный)

Кривая диаметра штуцера. Вводится в случае, если во время замера давления штуцер менялся.

Параметры:

  • Диаметр штуцера (тех. режим)

Это значение используется, если кривая диаметра не задана.

  • Температура на устье (изм. на тех. реж.)

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит по забойному давлению

Методика рассчитывает дебит жидкости по кривым давления, записанным во время снятия КВУ. Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

  • Забойное давление в затрубье

Давление с датчика, расположенного под затрубьем. Если не задано, принимается равным забойному давлению в НКТ

  • Буферное давление (Pb)

Если не задано, принимается равным атмосферному

  • Затрубное давление (Pzt)

Если не задано, принимается равным атмосферному

Параметры:

  • Плотность заполнителя ствола

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Диаметр НКТ внешний

Применяется для расчета геометрии затрубья

  • Внутренний диаметр эксплуатационной колонны

Применяется для расчета геометрии затрубья

  • Способ работы скважины

  1. По НКТ;

  2. По затрубью;

  3. По НКТ и затрубью;

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Глубина замера давления

  • Длина фильтра

Для предварительной фильтрации входных кривых давлений. 1 - фильтрация не производится

  • Тип фильтра

Для предварительной фильтрации входных кривых давлений

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит по коэффициенту послепритока

Методика использует рассчитанный ранее или введенный непосредственно в карту задания коэффициент послепритока для расчета дебита по забойному давлению. Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

Параметры:

  • Коэффициент послепритока

Это параметр интерпретации, на момент расчета данной методики он может быть еще не рассчитан. В этом случае в поле "Значение" появится надпись "Введите значение". Вы можете просто впечатать в это поле значение данного параметра, либо сначала воспользоваться методикой, которая его рассчитает.

  • Длина фильтра

Для предварительной фильтрации входной кривой давления. 1 - фильтрация не производится

  • Тип фильтра

Для предварительной фильтрации входной кривой давления

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит по продуктивности

Методика использует известный коэффициент продуктивности и значение пластового давления для расчета дебита по забойному давлению. Для расчета необходимо завести параметр цикла со значениями коэффициента продуктивности. Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

  • Продуктивность

Параметр цикла со значениями продуктивности

Параметры:

  • Измеренное пластовое давление

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит по Рзаб (КИИ,несколько секций)

Дебит по забойному давлению (КИИ, несколько секций)

Методика рассчитывает дебит жидкости по кривой забойного давления, записанной во время подъема динамического уровня в трубах ИПТ. Отличается от методики "Дебит по забойному давлению" технологии "Дебит жидкости" только тем, что приток присутствует только во внутритрубном пространстве. Данная методика позволяет рассчитать дебит при подъеме динамического уровня, при изменении диаметра труб по глубине. Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

Параметры:

  • Плотность заполнителя ствола

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Внутренний диаметр 1-й секции, м

  • Внутренний диаметр 2-й секции, м

  • Внутренний диаметр 3-й секции, м

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Глубина замера давления

  • Длина фильтра

Для предварительной фильтрации входных кривых давлений. 1 - фильтрация не производится

  • Тип фильтра

Для предварительной фильтрации входных кривых давлений

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит по Рзаб (КИИ,одна секция труб)

Дебит по забойному давлению (КИИ, одна секция труб)

Методика рассчитывает дебит жидкости по кривой забойного давления, записанной во время подъема динамического уровня в НКТ. Отличается от методики "Дебит по забойному давлению" технологии "Дебит жидкости" только тем, что приток присутствует только в НКТ. Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

Параметры:

  • Плотность заполнителя ствола

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Глубина замера давления

  • Длина фильтра

Для предварительной фильтрации входных кривых давлений. 1 - фильтрация не производится

  • Тип фильтра

Для предварительной фильтрации входных кривых давлений

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит по циклам свабирования

Методика рассчитывает дебит жидкости по кривым давления, записанным во время свабирования. Для расчета необходимо отметить циклами интервалы свабирования и выделить их желтыми интервалами.

Методика автоматически находит каждый цикл сваба и рассчитывает для каждого из них свой дебит. На выходе можно получить дебит для каждого сваба, либо осредненный для каждого выделенного интервала свабирования (желтого интервала) - см. параметр Осреднять дебиты.

Данная методика может применяться в отсутствие данных об объемах добытой жидкости для оценки дебита, однако результаты с большой вероятностью будут завышены из-за негерметичности сваба и аномального повышения забойного давления при спуске сваба.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

  • Забойное давление в затрубье

Давление с датчика, расположенного под затрубьем. Если не задано, принимается равным забойному давлению в НКТ

  • Буферное давление (Pb)

Если не задано, принимается равным атмосферному

  • Затрубное давление (Pzt)

Если не задано, принимается равным атмосферному

Параметры:

  • Плотность заполнителя ствола

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Диаметр НКТ внешний

Применяется для расчета геометрии затрубья

  • Внутренний диаметр эксплуатационной колонны

Применяется для расчета геометрии затрубья

  • Способ работы скважины

  1. По НКТ;

  2. По затрубью;

  3. По НКТ и затрубью;

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Глубина замера давления

  • Осреднять дебиты

  1. По выделенным циклам - значения непрерывной кривой дебита осредняются для каждого желтого интервала;

  2. По каждому свабу - для каждого сваба на непрерывной кривой дебита выдается свое значение;

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Дебит с учетом добытой жидкости (сваб.)

Дебит с учетом добытой жидкости (свабирование)

Методика рассчитывает дебит жидкости по кривым давления, записанным во время свабирования, и по данным о фактически добытой жидкости. Работает по первой и последней точкам отмеченных интервалов свабирования: для расчета необходимо отметить циклами интервалы свабирования и выделить их желтыми интервалами.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

  • Забойное давление в затрубье

Давление с датчика, расположенного под затрубьем. Если не задано, принимается равным забойному давлению в НКТ

  • Буферное давление (Pb)

Если не задано, принимается равным атмосферному

  • Затрубное давление (Pzt)

Если не задано, принимается равным атмосферному

  • Кол-во вытесненной жидкости (Gж)

Кривая - параметр цикла со значениями добытой жидкости в каждом интервале свабирования

Параметры:

  • Плотность заполнителя ствола

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Диаметр НКТ внешний

Применяется для расчета геометрии затрубья

  • Внутренний диаметр эксплуатационной колонны

Применяется для расчета геометрии затрубья

  • Способ работы скважины

  1. По НКТ;

  2. По затрубью;

  3. По НКТ и затрубью;

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Глубина замера давления

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Заб.давление и дебит по уровням (КВУ)

Забойное давление и дебит по уровням (КВУ)

Методика определяет забойное давление и дебит по кривым уровня в НКТ и затрубье, а также буферному и затрубному давлению, если есть данные о них.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Буферное давление (Pb)

Если не задано, принимается равным среднему буферному давлению

  • Затрубное давление (Pzt)

Если не задано, принимается равным буферному

  • Уровень в НКТ, м

Если не задан, принимается уровню в затрубье

  • Уровень в затрубье, м

Параметры:

  • Глубина расчета давления

Глубина, на которой будет рассчитано забойное давление

  • Плотность нефти в усл. пласта

  • Плотность воды в усл. пласта

  • Глубина нижнего конца НКТ фактическая

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Диаметр НКТ внешний

Применяется для расчета геометрии затрубья

  • Внутренний диаметр эксплуатационной колонны

Применяется для расчета геометрии затрубья

  • Обводненность флюида в НКТ

Используется для расчета плотности флюида

  • Обводненность флюида в колонне

Используется для расчета плотности флюида

  • Обводненность флюида в затрубье

Используется для расчета плотности флюида

  • Пространство послепритока

  1. По затрубью - дебит рассчитывается только по затрубью;

  2. По НКТ и затрубью - дебит рассчитывается по НКТ и затрубью;

  • Способ оценки забойного давления

  1. По буферному давлению - для расчета давления используется давление и уровень в НКТ;

  2. По затрубному давлению - для расчета давления используется давление и уровень в затрубье;

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Среднее буферное давление

  • Угол наклона ствола, град

Выходные кривые:

  • «Рзаб_расч»

Рассчитанное забойное давление

  • «Дебит_расч»

Рассчитанный дебит


Забойное давление ост. газ. скважины

Забойное давление остановленной газовой скважины

Методика пересчитывает замер давления, сделанный на устье газовой скважины, на глубину забоя. Подходит для пересчета затрубного давления по неподвижному столбу газа в затрубье.Работает только для газовых скважин.

Методика работает в желтых интервалах.

Методику можно вызвать из контекстного меню кривой.

Входные данные:

Кривые:

  • Устьевое давление

Кривая давления, записанная на устье

Параметры:

  • Глубина

Глубина, на которую требуется пересчитать замер. Нужно задать разницу между точкой замера и забоем.

  • Пластовая температура

  • Температура на устье (изм. на тех. реж.)

Выходные кривые:

  • «Рзаб»

Давление, пересчитанное на забой


Забойное давление по динам.уровням(режимы)

Забойное давление по динамическим уровням (режимы)

Методика рассчитывает забойное давление по динамическим уровням, измеренным на режимах. Работает по выделенным циклам.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Динамический уровень на режимах, м

Глубина регистрации давления

Параметры:

  • Альтитуда стола ротора

  • Температура на забое(изм.на тех.реж.)

  • Глубина замера давления

  • Плотность нефти в усл. пласта

Используется в зависимости от параметра Способ расчета плотности

  • Плотность дегазированной нефти

Используется в зависимости от параметра Способ расчета плотности

  • Относит.плотность газа по воздуху

Используется при расчете давления столба газа над динамическим уровнем

  • Плотность воды в условиях пласта

Используется в зависимости от параметра Способ расчета плотности

  • Плотность заполнителя ствола

Используется в зависимости от параметра Способ расчета плотности

  • Плотность по результатам измерений

Используется в зависимости от параметра Способ расчета плотности

  • Способ расчета плотности

  1. Рассчитывается по обводненности - осредняется плотность пластовой и дегазированной нефти, затем по данным обводненности и плотности воды рассчитывается средняя плотность;

  2. Вводится пользователем - используется параметр Плотность заполнителя ствола;

  3. Оценивается по измерениям в стволе - используется параметр Плотность по результатам измерений;

  • Способ расчета пластового давления

  1. БелНИПИ;

  2. Муравленко;

  3. Сургут;

  • Обводненность флюида в колонне

Используется в зависимости от параметра Способ расчета плотности

  • Устьев.дебит жидк.(изм. на тех.реж.)

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

Выходные кривые:

  • «Рзаб_реж»

Параметр цикла - расчетное забойное давление


Забойное давление раб. газ. скважины

Забойное давление работающей газовой скважины

Методика пересчитывает замер давления, сделанный на устье газовой скважины, на глубину забоя. Методику следует применять, если расчет по неподвижному столбу газа в затрубье некорректен (например, при эксплуатации скважины с пакером). Работает только для газовых скважин.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Устьевое давление

Кривая давления, записанная на устье

  • Дебит скважины (если переменный)

Кривая дебита для случая, когда во время замера дебит изменялся. Если дебит был постоянным, следует выбрать "не задано".

Параметры:

  • Глубина

Глубина, на которую требуется пересчитать замер. Нужно задать разницу между точкой замера и забоем.

  • Пластовая температура

  • Температура на устье (изм. на тех. реж.)

  • Коэффициент гидравлического сопротивления труб

Рассчитывается на основании данных о шероховатости труб, числе Рейнольдса и типе потока в трубах.

  • Внутренний диаметр эксплуатируемых труб

  • Дебит скважины (если постоянный)

Здесь задается дебит, если во время замера он не изменялся. Внимание! Если задана кривая дебита (см. выше), данное значение игнорируется,

Выходные кривые:

  • «Рзаб»

Давление, пересчитанное на забой


КД: линейные анаморфозы

Данная методика является аналогом методики "КД: нестабильный расход, однородный пласт". Разница между рассматриваемыми методиками в том, что для обработки полученной информации используются методы линейной анаморфозы: дифференциальный (стандартный, разностный и относительный), и интегральный (стандартный, разностный и относительный).

Исходными данными для расчетов являются кривая давления и кривая расхода. Последняя представляет собой непрерывную кривую, которая обычно рассчитывается с помощью методик раздела «Дебит жидкости»

Для обработки результатов используется МНК.

Методика рассчитывает проницаемость, скин-фактор, пластовое давление и другие параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в активном цикле.

Ж елтые интервалы определяют предысторию.

Входные данные:

Кривые:

  • Давление (P)

  • Дебит (Q)

Параметры:

  • Шаг свертки, с

Шаг свертки определяет разрешение, с которым будет проводиться свертка функции влияния. При современных возможностях компьютеров можно задать шаг в 1 с. Однако, если время исследования значительно (недели, месяцы), имеет смысл задать больший шаг, чтобы сэкономить время расчета и выделяемую память.

  • Аппроксимация функции влияния

  1. Логарифмическое приближение;

  2. Ei приближение;

Главное преимущество приближения логарифмом - скорость расчета. Тем не менее, это, хотя и хорошее, но все же приближение. Если время расчета некритично, желательно использовать функцию Ei.


КД:нестабильный расход,однор.пласт

КД: нестабильный расход, однородный пласт

Данная методика является наиболее общей и может быть использована для обработки кривых изменения давления в скважине при произвольном изменении дебита во времени.

Исходными данными для расчетов являются кривая давления и кривая расхода. Последняя представляет собой непрерывную кривую, которая обычно рассчитывается с помощью методик раздела «Дебит жидкости»

Для обработки результатов используется метод совмещения.

Методика рассчитывает проницаемость, скин-фактор, пластовое давление и другие параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в активном цикле.

Желтые интервалы определяют предысторию.

Входные данные:

Кривые:

  • Давление (P)

  • Дебит (Q)

Параметры:

  • Шаг свертки, с

Шаг свертки определяет разрешение, с которым будет проводиться свертка функции влияния. При современных возможностях компьютеров можно задать шаг в 1 с. Однако, если время исследования значительно (недели, месяцы), имеет смысл задать больший шаг, чтобы сэкономить время расчета и выделяемую память.

  • Аппроксимация функции влияния

  1. Логарифмическое приближение;

  2. Ei приближение;

Главное преимущество приближения логарифмом - скорость расчета. Тем не менее, это, хотя и хорошее, но все же приближение. Если время расчета некритично, желательно использовать функцию Ei.


Компоновка диаграмм

Методика склеивает одну кривую из нескольких участков разных кривых.

Необходимо выделить желтым интервалом участок исходной кривой, который необходимо получить в результирующей кривой, и запустить методику. Таким образом, в несколько приемов формируется склеенная кривая. Склеиваемые кривые должны быть одной физической величины и в одних единицах измерения.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Исходная кривая для склейки

Выходные кривые:

  • «skle»

Результат склейки


Кроссплот PVT и фазовых проницаемостей

Кроссплот PVT-свойств и фазовых проницаемостей

Кроссплот предназначен для визуализации и расчета основных параметров для нефти и газа, а также для нормировки и визуализации кривых относительных фазовых проницаемостей.

Рассчитанные параметры могут быть сохранены в рабочий набор данных, в этом случае их вновь рассчитанные значения будут доступны для всех остальных методик программы.

После нажатия кнопки "Расчет" в окне выбора методики, появится кроссплот:

В заголовке кроссплота можно увидеть название текущей методики. Переключить методику можно с помощью панели инструментов:

В четырех блоках кнопок можно выбрать методики

PVT-свойств нефти:

вязкость,

сжимаемость,

коэффициент объемного расширения,

PVT-свойств воды:

вязкость,

сжимаемость,

PVT-свойств газа:

сверхсжимаемость,

вязкость,

плотность,

фазовой проницаемости:

нефть + вода,

вода + газ,

газ + нефть.

На основной панели инструментов доступны следующие опции:

- входные параметры текущей методики,

- рассчитанные по текущей методике параметры,

- ввод исходных данных и выбор алгоритмов расчета PVT-свойств флюида,

- изменение размера шрифтов на итоговой картинке,

- печать изображения на принтер,

- печать изображения в файл,

- запись изображения в файл заключения Excel.

В окне входных параметров

можно ввести значения параметров для текущей методики.

Параметр "Дискретность визуализации" определяет, сколькими линиями будет представлен на кроссплоте переход от начальных до конечных температуры и давления.

С помощью кнопки "Печать в XLS" можно добавить таблицу входных параметров в файл заключения Excel.

В окне выходных параметров

можно просмотреть рассчитанные значения параметров и записать их в рабочий набор данных либо все сразу (с помощью кнопки "Все выходные в РНД"), либо по отдельности, выделяя параметр и нажимая кнопку "В РНД".

Если значение параметра выделено красным, значит, его значение лежит вне допустимых в РНД пределов и оно не будет записано в РНД. Предупреждение об этом будет отображено при попытке его записи.

Таблицу выходных параметров также можно напечатать в файл заключения Excel при помощи кнопки "Сохранить в XLS".

Также в заключение можно добавить таблицу состава газа в виде круговой диаграммы, кнопка для этого присутствует на форме ввода состава газа.

График можно настроить по своему усмотрению, выбрав нужный масштаб с помощью ZOOM'а левой кнопкой мыши. Кроме того, по правой кнопке мыши доступно меню со следующими опциями:

Свойства активной кривой... - позволяет редактировать цвет, толщину линии и размеры, форму и цвет точек активной кривой. Активная кривая выделяется прямоугольником в окне легенды справа. Сделать кривую активной можно, выбрав ее в окне легенды, либо кликнув на кривую в основном окне.

Показывать активную кривую - включает/отключает отображение активной кривой.

Предыдущий масштаб - откатывает изменение масштаба к состоянию до последнего ZOOM'а.

Исходный масштаб - возвращает масштаб к исходному, полностью отображая все кривые.

Горизонтальная сетка, Вертикальная сетка - включают/отключают отображение соответствующей масштабной сетки.

Копировать в буфер - копируют в буфер обмена Windows изображение кроссплота для дальнейшей вставки в любой файл заключения, отчета и т. д.

При движении курсора вдоль кривых в строке состояния подписываются координаты ближайших к курсору точек кривых, а также шифр активной кривой.


Метод индикаторной

Методика предназначена для определения параметров пласта по результатам измерений давления и дебита на серии режимов стабильной работы скважины, отличающихся депрессией на пласт. Для определения параметров пласта используется метод построения индикаторной диаграммы. Точки снимаются с выделенных желтыми интервалами циклов. Если кривая давления непрерывная, то для каждого цикла используется последняя точка давления в нем, так как давление стабилизируется к концу режима.

Для обработки результатов используется МНК.

Методика рассчитывает фильтрационные параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Давление (P)

  • Дебит (Q)


Метод индикаторной

Метод индикаторной (газ)

Методика предназначена для определения параметров пласта по результатам измерений давления и дебита на серии режимов стабильной работы скважины, отличающихся депрессией на пласт. Для определения параметров пласта используется метод построения индикаторной диаграммы. Точки снимаются с выделенных желтыми интервалами циклов. Если кривая давления непрерывная, то для каждого цикла используется последняя точка давления в нем, так как давление стабилизируется к концу режима.

Для обработки результатов используется МНК.

Методика рассчитывает фильтрационные параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Давление (P)

  • Дебит (Q)

Параметры:

  • Тип индикаторной линии

Определяет вид аппроксимации и набор расчетных параметров

  1. AQ;

  2. BQ2;

  3. AQ+BQ2;

  • Измеренное пластовое давление


Метод индикаторной КВУ (Яковлева)

Работа по данной методике аналогична работе по "Методу индикаторной". Разница состоит в том, что индикаторная диаграмма строится не по средним значениям с каждого цикла, а по временному интервалу, во время которого давление и дебит непрерывно и интенсивно меняются. В этом случае координатами точек индикаторной диаграммы являются значения давления и дебита для каждой точки исходных кривых. Точки снимаются с кривой в пределах активного (зеленого) цикла.

Для обработки результатов используется МНК.

Методика рассчитывает фильтрационные параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в активном цикле.

Входные данные:

Кривые:

  • Давление (P)

  • Дебит (Q)


Модель

Данная методика предназначена для обработки кривых восстановления, стабилизации или падения давления. Перед расчетом задается модель скважины, пласта и тип флюида.

Исходными данными для расчетов являются кривая давления и данные о дебите в цикле КВД и предшествующих циклах (предыстория).

Для обработки результатов используется МНК.

Методика рассчитывает параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в активном цикле.

Желтые интервалы определяют предысторию.

Входные данные:

Кривые:

  • Давление (P)

  • Дебит (Q)

  • Дебит газа (Q)

  • Способ определения начального времени

  1. С границы цикла;

  2. Взять с ближайшей точки;

  3. Аппроксимировать по 4 ближайшим точкам;

В зависимости от типа флюида, которым работает скважина, задается только один дебит. Для другого нужно выбрать опцию "Не задано".

Вход в методику, кроме панели технологий, также может осуществляться с помощью кнопки [image] на основной панели инструментов.

После нажатия кнопки "Расчет" появится диалог выбора модели. В выпадающих списках можно выбрать:

тип скважины

геометрию пласта

границу

тип границы

тип флюида (задается автоматически в зависимости от того, какой дебит задан)

и задать имя модели. Имя используется при записи в Базу Данных (в версии с базой).

Необходимо заполнить все параметры модели, не оставив значения "Отсутствует" ни в одном из них. После нажатия кнопки "Расчет" появится кроссплот:

В заголовке кроссплота можно увидеть атрибуты модели.

На основной панели инструментов, кроме описанных в разделе общей функциональности, доступны следующие опции:

- смена текущей модели (все выделенные режимы течения будут удалены, параметры интерпретации также будут удалены из РНД),

- точное задание начальной температуры и давления,

- отключение предыстории,

- печать таблицы точек в файл заключения Excel,

- проверка характерных для различных режимов углов наклона производной в масштабе LOG-LOG,

- выбрать левым кликом на кроссплоте левую границу обработки,

- выбрать левым кликом на кроссплоте правую границу обработки,

- расширить границы обработки влево,

- сузить границы обработки слева,

- сузить границы обработки справа,

- расширить границы обработки вправо,

- отменить последнее действие с интервалами и границами обработки (установку, подвижку границ, удаление).

Обработка осуществляется расстановкой интервалов различных режимов течения. Для этого на панели интервалов:

выберите необходимый интервал и установите его на кроссплоте, кликнув левой кнопкой мыши у одной границы и протащив курсор до другой. Типы интервалов отображаются на всплывающих подсказках. Отмена назначения интервалов осуществляется повторным нажатием на кнопку выбора того же интервала. Для изменения границ интервала подведите указатель мыши к границе. Курсор изменится на такой: . После этого просто перетащите границу с помощью левой кнопки мыши.

Интервалы имеют установленный порядок - тот же, в котором расположены кнопки на панели интервалов. Программа не позволит установить их в другом порядке.

Интервалы могут быть пропущены, однако в этом случае некоторые параметры не будут рассчитаны.

Расчеты ведутся для 15 возможных режимов течения, в том числе:

VBS – послеприток;

ER – ранний радиальный;

HR – полурадиальный;

PR – псевдорадиальный;

RF – радиальный по трещинам;

LR – поздний псевдорадиальный;

RM – радиальный по матрице;

EL – ранний линейный по трещине;

LI – линейный по трещине;

BI – билинейный по трещине;

LL – поздний линейный;

G1 – локальный отклик (внешняя граница);

G2 – линейный поток (русло);

G3 – истощение (линза);

SE – сферический;

HE – полусферический.

Из перечисленных режимов течения будет предложено выбрать лишь те, наличие которых возможно в условиях выбранной модели.

В каждом интервале осуществляется расчет МНК для производной. Можно отбраковать точку или группу точек, выделив их область левой кнопкой мыши и выбрав пункт "Деактивировать точки":

Изображение точек изменится, и они будут также выключены из расчета. Включить их обратно в расчет можно, повторив эту операцию и выбрав пункт меню "Активировать точки".

Просмотр графика давления и производной возможен в различных масштабах, переключение осуществляется с помощью панели масштабов:

Масштабы по порядку:

- двойной логарифмический масштаб (по оси ординат –давление или приращение давления, по оси абсцисс ординат - временная функция суперпозиции MDH в логарифмических координатах);

- декартовы координаты;

- координаты Хорнера для радиальных и псевдорадиальных режимов течения

(временная функция суперпозиции в логарифмических координатах);

- координаты MDH для радиальных и псевдорадиальных режимов течения

(временная функция суперпозиции в логарифмических координатах);

- координаты Хорнера для линейных режимов течения

(временная функция суперпозиции в координатах t 1/2);

- координаты MDH для линейных режимов течения

(временная функция суперпозиции в координатах t 1/2);

- координаты Хорнера для билинейного режима течения

(временная функция суперпозиции в координатах t 1/4);

- координаты MDH для билинейного режима течения

(временная функция суперпозиции в координатах t 1/4);

- координаты Хорнера для сферического режима течения

(временная функция суперпозиции в координатах t -1/2);

- координаты MDH для сферического режима течения

(временная функция суперпозиции в координатах t -1/2);

Переключатель P и P-Pо позволяет просмотреть на оси ординат давление или разницу текущего и начального давления.

Выбирать режимы удобнее всего в двойном логарифмическом масштабе, где наиболее рельефно видны особенности кривой давления, позволяющие диагностировать тип модели и режим течения.

Предыстория для масштабов определяется циклами, выделенными желтыми интервалами. К ним сверху пристыковывается предыстория, заданная в таблице предыстории.

Легенда отображается в верхней центральной области кроссплота:

переключение активной кривой производится левым кликом либо на кривую, либо на ее название в легенде. Активная кривая выделена в легенде серым прямоугольником.


Нестаб. работа, гидропрослушивание

Нестабильная работа скважины, гидропрослушивание

Методика предназначена для расчета теоретической кривой давления при заданном непрерывном дебите другой скважины. Она является аналогом предыдущей методики, но вместо диаметра скважины и скин-фактора используется расстояние между скважинами. В качестве входных подаются параметры пласта. Предыстория как и методике Модель задается совокупно желтыми интервалами и таблицей предыстории. Циклы, в которых рассчитывается кривая, задаются выделением активного цикла.

Комплексные параметры гидропроводность и пьезопроводность можно предварительно рассчитать в калькуляторе в методике "Гидро- и пьезопроводность пласта" в пакете "Параметры нефтяного пласта".

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Дебит (Q)

Непрерывная кривая дебита

Параметры:

  • Шаг свертки, с

  • Гидропроводность

  • Пьезопроводность

  • Расстояние между скважинами

  • Обводненность продукции

  • Измеренное пластовое давление

Выходные кривые:

  • «Pt(Qt)_ГП»

Рассчитанное забойное давление


Нестабильная работа

Нестабильная работа скважины

Методика предназначена для расчета теоретической кривой давления при заданном непрерывном дебите. В качестве входных подаются параметры пласта. Предыстория как и методике Модель задается совокупно желтыми интервалами и таблицей предыстории. Циклы, в которых рассчитывается кривая, задаются выделением активного цикла.

Комплексные параметры гидропроводность и пьезопроводность можно предварительно рассчитать в калькуляторе в методике "Гидро- и пьезопроводность пласта" в пакете "Параметры нефтяного пласта".

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Дебит (Q)

Непрерывная кривая дебита

Параметры:

  • Шаг свертки, с

  • Гидропроводность

  • Пьезопроводность

  • Диаметр ствола под экспл. колонну

  • Интегральный скин-фактор

  • Обводненность продукции

  • Измеренное пластовое давление

Выходные кривые:

  • «Pt(Qt)»

Рассчитанное забойное давление


Осреднение по циклам

Методика осредняет входную кривую в интервалах колодца циклов

Входные данные:

Кривые:

  • Входная кривая

Выходные кривые:

  • «имя входной кривой_ст»

Ступенчатая кривая - параметр цикла


Параметры пласта по Маскету

Методика реализует стандартный метод Маскета. Пластовое давление (точнее – восстановленное забойное давление на глубине измерения) в этом методе определяется методом подбора. Для проверки правильности подбора кривая перестраивается в логарифмические координаты. Если давление подобрано неверно, график изменения давления во времени в этих координатах имеет кривизну. При вводе пластового давления, близкого к реальному график приобретает линейный вид. Точки снимаются с кривой в пределах активного (зеленого) цикла.

Для обработки результатов используется МНК.

Методика рассчитывает фильтрационные параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в активном цикле.

Входные данные:

Кривые:

  • Давление (P)


Параметры пласта по Маскету(дифф.)

Параметры пласта по Маскету (дифференциальный метод)

Дифференциальный метод Маскета предполагает анализ не аномалии давления, а темпа его изменения во времени. Это позволяет оценивать продуктивность пласта в отсутствие данных о восстановленном пластовом давлении. Это является несомненным преимуществом данной методики. Недостаток данного способа расчетов состоит в существенной зависимости результата от точности регистрации давления, поскольку предусматривается численное дифференцирование кривой давления. Вследствие этой причины результат может быть сильно искажен; чтобы этого избежать, перед использованием методики кривую давления необходимо сгладить. Точки снимаются с кривой в пределах активного (зеленого) цикла.

Для обработки результатов используется МНК.

Методика рассчитывает фильтрационные параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в активном цикле.

Входные данные:

Кривые:

  • Давление (P)


Парам.пласта по Муравьеву-Крылову

Параметры пласта по Муравьеву-Крылову

Данная методика является модификацией метода индикаторной Яковлева. Специфика обработки этим методом состоит в том, что сопоставляются не данные по давлению и дебиту, а данные по давлению и производной давления по времени. Точки снимаются с кривой в пределах активного (зеленого) цикла.

Для обработки результатов используется МНК.

Методика рассчитывает фильтрационные параметры пласта.

Это кроссплотная методика, см. описание Функциональности кросс-плота.

Методика работает в активном цикле.

Входные данные:

Кривые:

  • Давление (P)


Пересчет давления на кровлю перфорации

Методика пересчитывает замер давления, сделанный на некоторой фиксированной глубине, на глубину кровли перфорации. Работает только для водонефтяных скважин.

Методика работает в желтых интервалах.

Методику можно вызвать из контекстного меню кривой.

Входные данные:

Кривые:

  • Исходная кривая

Кривая давления, записанная на некоторой глубине

Параметры:

  • Глубина замера давления

Глубина, на которой проводился замер

  • Способ учета искривления скважины

  1. По удлинению - для приведения к абсолютной используется величина удлинения на глубине замера;

  2. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  3. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Удлинение на глубине замера

  • Кровля интервала перфорации

Выпадающий список. Интервалы перфорации нужно предварительно занести в РНД. Если Вы видите надпись "Не задана перфорация", это означает, что в РНД не задано ни одного интервала перфорации.

  • Удлинение на глубине кровли перфорации

  • Плотность нефти в условиях пласта

Используется для расчета давления столба водонефтяной смеси

  • Плотность воды в условиях пласта

Используется для расчета давления столба водонефтяной смеси

  • Обводнен.продукции(изм.на тех.реж.)

Используется для расчета давления столба водонефтяной смеси

Выходные кривые:

  • «имя входной кривой_prf»

Давление, пересчитанное на кровлю перфорации


Пересчет давления на отметку ВНК

Методика пересчитывает замер давления, сделанный на некоторой фиксированной глубине, на глубину водо-нефтяного контакта.

Методика работает в желтых интервалах.

Методику можно вызвать из контекстного меню кривой.

Входные данные:

Кривые:

  • Исходная кривая

Кривая давления, записанная на некоторой глубине

Параметры:

  • Глубина замера давления

Глубина, на которой проводился замер

  • Способ учета искривления скважины

  1. По удлинению - для приведения к абсолютной используется величина удлинения на глубине замера;

  2. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  3. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Удлинение на глубине замера

  • Абсолютная отметка ВНК

  • Альтитуда стола ротора

  • Плотность нефти в условиях пласта

Используется для расчета давления столба водонефтяной смеси

  • Плотность воды в условиях пласта

Используется для расчета давления столба водонефтяной смеси

  • Обводнен.продукции(изм.на тех.реж.)

Используется для расчета давления столба водонефтяной смеси

Выходные кривые:

  • «имя входной кривой_vnk»

Давление, пересчитанное на отметку ВНК


Пересчет давления на отметку ГВК

Методика пересчитывает замер давления, сделанный на некоторой фиксированной глубине, на глубину газо-водяного контакта.Данные о составе газа берутся из рабочего набора.

Методика работает в желтых интервалах.

Методику можно вызвать из контекстного меню кривой.

Входные данные:

Кривые:

  • Исходная кривая

Кривая давления, записанная на некоторой глубине

Параметры:

  • Глубина замера давления

Глубина, на которой проводился замер

  • Способ учета искривления скважины

  1. По удлинению - для приведения к абсолютной используется величина удлинения на глубине замера;

  2. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  3. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Удлинение на глубине замера

  • Пластовая температура

Используется для расчета плотности газа

  • Абсолютная отметка ГВК

  • Альтитуда стола ротора

  • Плотность воды в условиях пласта

Используется для расчета давления столба газоводяной смеси

  • Обводнен.продукции(изм.на тех.реж.)

Используется для расчета давления столба газоводяной смеси

Выходные кривые:

  • «имя входной кривой_gvk»

Давление, пересчитанное на отметку ГВК


Пересчет давления на постоянное Pуст

Пересчет давления на постоянное Р уст

Методика производит поправку замера давления в скважине за изменение устьевого давления. Замер приводится к условиям, когда устьевое давление постоянно и равно его значению в первой точке кривой.

Методика работает в желтых интервалах.

Методику можно вызвать из контекстного меню кривой.

Входные данные:

Кривые:

  • Исходное давление

Кривая давления, записанная в скважине

  • Устьевое давление

Кривая устьевого давления

Выходные кривые:

  • «имя входной кривой_cor»

Давление, поправленное за изменение устьевого


Плотность и состав по Рзаб

Плотность и состав по забойному давлению

Методика используется для расчета плотности заполнителя ствола по результатам дискретных замеров давления на дискретных глубинах (на так называемых «полках»). Параллельно на основании полученных результатов рассчитывается и выдается в протокол давление в стволе на глубинах, где его непосредственное измерение не было произведено. Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

  • Глубина, м

Глубина регистрации давления

Параметры:

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Абсолютная отметка ВНК

  • Кровля интервала перфорации

Выпадающий список. Интервалы перфорации нужно предварительно занести в РНД. Если Вы видите надпись "Не задана перфорация", это означает, что в РНД не задано ни одного интервала перфорации.

  • Обводнен.продукции(изм.на тех.реж.)

Коэффициент содержания воды в отобранной продукции

Выходные кривые:

  • «Плотность»

Плотность флюида

  • «Рзаб_расч»

Расчетное забойное давление


Плотность и состав по Pзаб, газ

Плотность и состав по забойному давлению, газ

Методика используется для расчета плотности заполнителя ствола по результатам дискретных замеров давления на дискретных глубинах (на так называемых «полках»). Параллельно на основании полученных результатов рассчитывается и выдается в протокол давление в стволе на глубинах, где его непосредственное измерение не было произведено. Работает по всем точкам кривых в пределах желтых интервалов.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

  • Глубина, м

Глубина регистрации давления

  • Термограмма (Тг)

Температура в скважине

Параметры:

  • Средняя температура

Средняя температура в скважине

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Абсолютная отметка ВНК

  • Кровля интервала перфорации

Выпадающий список. Интервалы перфорации нужно предварительно занести в РНД. Если Вы видите надпись "Не задана перфорация", это означает, что в РНД не задано ни одного интервала перфорации.

  • Обводнен.продукции(изм.на тех.реж.)

Коэффициент содержания воды в отобранной продукции

Выходные кривые:

  • «Плотн.газа при СУ»

Плотность газа при стандартных условиях

  • «Рзаб_расч»

Расчетное забойное давление

  • «Плотн.газа в скв.»

Плотность газа в скважинных условиях


Плотность по давлению и уровням

Методика определяет расходные плотности в НКТ и затрубье по кривым забойного давления, уровня в НКТ и затрубье, а также буферному и затрубному давлению, если есть данные о них. Кроме того, в протокол выдаются дебиты, рассчитанные для интервала исследований.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

  • Буферное давление (Pb)

Если не задано, принимается равным атмосферному

  • Затрубное давление (Pzt)

Если не задано, принимается равным буферному

  • Уровень в НКТ, м

Если не задан, принимается уровню в затрубье

  • Уровень в затрубье, м

Параметры:

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Диаметр НКТ внешний

Применяется для расчета геометрии затрубья

  • Внутренний диаметр эксплуатационной колонны

Применяется для расчета геометрии затрубья

  • Плотность дегазированной нефти

  • Плотность воды в усл. пласта

  • Пластовая температура

  • Тип флюида

  1. Вода + нефть;

  2. Вода + газ;

  3. Нефть + газ;

  4. Вода + нефть + газ;

Выходные кривые:

  • «Ro_NKT»

Рассчитанное забойное давление

  • «Ro_ZT»

Рассчитанный дебит


Приведзамера по стволу к фиксглубине

Приведение замера по стволу к фиксированной глубине

Методика пересчитывает замер давления, сделанный движущимся прибором, на заданную фиксированную глубину. Скорость движения прибора предполагается постоянной. Работает только для водонефтяных скважин.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Давление в скважине

Кривая давления, записанная движущимся прибором

Параметры:

  • Способ учета искривления скважины

  1. По удлинению - для приведения к абсолютным используются величины удлинений;

  2. По среднему углу наклона - для приведения к абсолютным используется средний угол наклона ствола;

  3. По инклинограмме - для приведения к абсолютным используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Глубина замера давления

Глубина, на которую должен быть пересчитан замер

  • Удлинение на глубине замера

  • Глубина начала записи

  • Удлинение на глубине начала записи

  • Глубина конца записи

  • Удлинение на глубине конца записи

  • Плотность нефти в условиях пласта

Используется для расчета давления столба водонефтяной смеси

  • Плотность воды в условиях пласта

Используется для расчета давления столба водонефтяной смеси

  • Обводнен.продукции(изм.на тех.реж.)

Используется для расчета давления столба водонефтяной смеси

Выходные кривые:

  • «имя входной кривой_z»

Давление, приведенное к требуемой глубине


Продуктивность по режимам

Методика рассчитывает коэффициент продуктивности по давлению и дебиту. Работает в выделенных циклах. Если на вход подается непрерывная кривая давления, для расчета используется последняя точка, так как стабилизация давления наступает ближе к концу режима. Также можно подать на вход давление - параметр цикла, тогда значения можно задать вручную. Рассчитанный коэффициент продуктивности имеет смысл только для скважин, работающих жидкостью.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Давление (P)

Забойное давление

  • Дебит (Q)

Параметр цикла со значениями дебита для режимов

Параметры:

  • Измеренное пластовое давление

Пластовое давление, по которому будет определяться продуктивность

Выходные кривые:

  • «Кпрод

Рассчитанный коэффициент продуктивности


Просмотр в LOG-LOG масштабе

Методика позволяет предварительно просмотреть кривую давления и ее логарифмическую производную на кроссплоте в билогарифмическом масштабе. Предыстория при построении кривых не учитывается.

Методика работает в активном цикле.

Входные данные:

Кривые:

  • Кривая давления


Просмотр в реальном м-бе времени

Просмотр в реальном масштабе времени

Методика позволяет просмотреть несколько кривых на кроссплоте в масштабе, где на оси абсцисс - время.

На кроссплоте может быть 4 масштаба, отображающихся слева или справа от двух осей ординат, в каждом из масштабов можно просмотреть не более 3 кривых.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Масштаб 1 кривая 1

  • Масштаб 1 кривая 2

  • Масштаб 1 кривая 3

  • Масштаб 2 кривая 1

  • Масштаб 2 кривая 2

  • Масштаб 2 кривая 3

  • Масштаб 3 кривая 1

  • Масштаб 3 кривая 2

  • Масштаб 3 кривая 3

  • Масштаб 4 кривая 1

  • Масштаб 4 кривая 2

  • Масштаб 4 кривая 3


Сглаживание кривых

Методика сглаживает исходную кривую выбранным фильтром.

Также для сглаживания можно использовать функцию сглаживания на панели инструментов

и диалог фильтрации.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Кривая для сглаживания

Параметры:

  • Длина фильтра

Глубина окна сглаживания

  • Тип фильтра

  1. Осредняющий - простое среднее в скользящем окне;

  2. Линейный - в пределах окна сглаживания исходная кривая приближается прямой;

  3. Параболический - в пределах окна сглаживания исходная кривая приближается параболой;

  4. Экспоненциальный - в пределах окна сглаживания исходная кривая приближается экспонентой;

  5. Медианный - в пределах окна сглаживания точки сортируются. Точка со средней позиции ставится в центр окна.

Выходные кривые:

  • «имя входной кривой_sgl»

Сглаженная кривая


Содержание воды по плотности

Методика определяет содержание воды во флюиде по кривым плотности в НКТ и затрубье.

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Расходная плотность в НКТ

  • Расходная плотность в затрубье

Параметры:

  • Плотность нефти в усл. пласта

  • Плотность воды в усл. пласта

Выходные кривые:

  • «Wat_NKT»

Содержание воды в НКТ

  • «Wat_ZT»

Содержание воды в затрубье


Средн. дебит по заб. давлению (КИИ)

Средний дебит по забойному давлению (КИИ)

Методика позволяет рассчитать средний дебит для каждого заданного временного цикла при подъеме динамического уровня по внутритрубному пространству по разнице начального и конечного давлений. Работает по первой и последней точкам кривой в каждом желтом интервале..

Методика работает в желтых интервалах.

Методика выдает протокол работы.

Входные данные:

Кривые:

  • Забойное давление в НКТ (Pzab)

Давление с датчика, расположенного под НКТ

Параметры:

  • Плотность заполнителя ствола

  • Диаметр НКТ внутренний

Применяется для расчета геометрии НКТ

  • Способ учета искривления скважины

  1. По среднему углу наклона - для приведения к абсолютной используется средний угол наклона ствола;

  2. По инклинограмме - для приведения к абсолютной используется таблица инклинометрии;

  • Угол наклона ствола, град

  • Глубина замера давления

Выходные кривые:

  • «Qpk»

Рассчитанный дебит


Стабильная работа скважины

Методика предназначена для расчета теоретической кривой давления при заданных режимах отбора (закачки). В качестве входных подаются параметры пласта. Предыстория как и методике Модель задается совокупно желтыми интервалами и таблицей предыстории. Циклы, в которых рассчитывается кривая, задаются выделением активного цикла.

Комплексные параметры гидропроводность и пьезопроводность можно предварительно рассчитать в калькуляторе в методике "Гидро- и пьезопроводность пласта" в пакете "Параметры нефтяного пласта".

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Дебит (Q)

Ступенчатый дебит - параметр цикла

Параметры:

  • Гидропроводность

  • Пьезопроводность

  • Измеренное пластовое давление

  • Диаметр ствола под экспл. колонну

  • Интегральный скин-фактор

  • Обводненность продукции

  • Число точек на цикл

Задает сколько будет точек в выходной кривой для каждого цикла. Точки будут распределены логарифмически.

Выходные кривые:

  • «Pt»

Рассчитанное забойное давление


Стаб.раб.,гидропрослушивание

Стабильная работа скважины, гидропрослушивание

Методика предназначена для расчета теоретической кривой давления при заданных режимах отбора (закачки) в другой скважине. Она является аналогом предыдущей методики, но вместо диаметра скважины и скин-фактора используется расстояние между скважинами. В качестве входных подаются параметры пласта. Предыстория как и методике Модель задается совокупно желтыми интервалами и таблицей предыстории. Циклы, в которых рассчитывается кривая, задаются выделением активного цикла.

Комплексные параметры гидропроводность и пьезопроводность можно предварительно рассчитать в калькуляторе в методике "Гидро- и пьезопроводность пласта" в пакете "Параметры нефтяного пласта".

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Дебит (Q)

Ступенчатый дебит - параметр цикла

Параметры:

  • Гидропроводность

  • Пьезопроводность

  • Измеренное пластовое давление

  • Расстояние между скважинами

  • Обводненность продукции

  • Число точек на цикл

Задает сколько будет точек в выходной кривой для каждого цикла. Точки будут распределены логарифмически.

Выходные кривые:

  • «Pt_ГП»

Рассчитанное забойное давление


Удаление дублирующих значений

Методика находит последовательности повторяющихся значений на кривой и заменяет их одной точкой. Глубина результирующей точки будет находиться посередине бывшего интервала с одинаковым значением.

Методику удобно применять, когда темп изменения кривой меньше, чем разрешающая способность прибора. В этом случае дополнительные точки, не несущие полезной информации, засоряют кривую и портят ее производную.

Использовать методику следует когда кривая давления выглядит следующим образом:

В некоторых случаях ступенчатость кривой осложняется зашумленностью кривой, тогда точки кривой выглядят как тренд:

Тогда перед применением методики следует применить медианное сглаживание, которое приведет кривую к виду, показанному на первом рисунке.

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Кривая

Выходные кривые:

  • «имя входной кривой_new»

Кривая, очищенная от повторяющихся значений


Функциональные преобразования

Расчет математической функции от входной кривой

Методика работает в желтых интервалах.

Входные данные:

Кривые:

  • Исходная кривая

Параметры:

  • Тип преобразования

Один из видов математических функций, "x" - значения входной кривой

  • Коэффициент A

  • Коэффициент B

  • Коэффициент C

  • Коэффициент D

Выходные кривые:

  • «имя входной кривой_fun»

Рассчитанная кривая